1

Possible Duplicate:
How do you reset a USB device from the command line?

I have CE682 USB Modem connected using wvdial.

Every time it got disconnected, i cant reconnect without unplug and replug. If i execute wvdial without replug, it will only throw meaningless junk in the terminal as shown here:

enter image description here

How do I reset the USB modem without having to unplug each time it got disconnected?

  • Thank You @TomBrossman even tho my modem is not a camera i tried your suggestion: Downloaded Li Lio's script and do usb reset: $lsusb Bus 002 Device 033: ID 201e:1022 $sudo ./usbreset /dev/bus/usb/002/033 Resetting USB device /dev/bus/usb/002/033 Reset successful $sudo wvdial smart result: --> Waiting for carrier. ATDT#777 OK and hang until i pressed ctrl-c IF i waited quite long before typing wvdial smart, it got the carrier, but with this as the result: --> Disconnecting at Mon Oct 1 10:31:34 2012 --> The PPP daemon has died: Loopback detected (exit code = 17) – user85510 Oct 1 '12 at 3:52
  • also tried sskolow's tip, it was fruitless, only get an increasing device number in lsusb. But the modem is not recognized by wvdial, even after modprobe. – user85510 Oct 1 '12 at 3:53

Browse other questions tagged or ask your own question.