7

I have notice that since a few days my cap lock stays on if I press on caps lock. I can't desactivate it. I am currently using Ubuntu 12.04LTS on my old Emachines computer. So I would like to know where is the command to get back the default settings when I press the caps lock.

0
13

For 16.04 LTS and newer:

Unfortunately disabling CapsLock can no longer be done from the keyboard system settings as depicted below. We will have to install and run dconf-editor to add 'caps:none' to or.gnome.desktop.input- sources.xkb-options.

sudo apt install dconf-editor

enter image description here

This can also be done from a terminal with the following command:

dconf write /org/gnome/desktop/input-sources/xkb-options "['caps:none']"

For 14.04 and older:

Click on the Ubuntu button and search for "Keyboard Layout" and select "Options..." or from System Settings... open the "Keyboard Layout" and select "Options...".

Look for the Caps Lock key behaviour entry and unfold the list of options to give you this:

enter image description here

4
  • for even newer ones, adding 'ctrl:nocaps' in the array of xkb-options in dconf-editor did the trick for me (ubuntu Wily 15.10). Jan 25 '16 at 9:24
  • Is there any way to get to this menu in 16.04? Nov 2 '17 at 20:26
  • @NathanHinchey: thank your for that hint... sadly this option was deprecated 16.04. See edit for the dconf way.
    – Takkat
    Nov 2 '17 at 20:58
  • Doesn't seem to work on Xubuntu 18.04.
    – To Do
    Jul 28 '18 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.