I am attempting to install Ubuntu 12.04.1 LTS on a Sony Vaio Laptop, the laptop's primary screen is non-functional. I run into a problem on the screen following the creation of a username/password. It appears to want me to select an avatar. I get an error relating to the webcam it seems when I look in the /var/log/syslogs. I am able to boot from the disc no problem.

I have seen several suggestions here and elsewhere to use the alternate installer. It appears that the alternate installer does not load up the drivers for secondary monitors, so I am unable to see if any progress is being made or not. Is there a link that contains the steps that the alternate installer goes through ? Or a way to get that installer to load the second screen as well ?

It looks like this bug: https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1021449


Enter BIOS settings for the Vaio and turn the web cam off. When you get to the section in the install to select the Avatar, simply click on one of the alternate avatars to the right and continue with the installation.

Since you don't appear to be able to turn the camera off in BIOS, we could try removing the module for it before you start the install. Boot up the LiveCD or LiveUSB and select "try Ubuntu" When you get to the desktop open a terminal window and type:

sudo modprobe -r uvcvideo

Then click "install".

Removing the generic USB webcam device module should prevent the install program from trying to use the camera when it gets to the avatar setup page.

| improve this answer | |
  • Unfortunately there doesn't seem to be a way to do that in the sony vaio bios utility. I tried on a separate machine (because I can't see the laptop's bios utility due to the broken primary screen) and there isn't a way to disable the webcam there. – Andres Sep 29 '12 at 23:52
  • removing the usb webcam module worked. Thanks fabricator4 – Andres Sep 30 '12 at 18:08
  • I've also confirmed the bug report on Launchpad and entered a comment that links back to this question. Hopefully the work around will be useful for people and the bug will get some work and attention in the future. – fabricator4 Sep 30 '12 at 22:43
  • When I first tried to install Ubuntu 12.04.1 on my ASUS A8JS notebook, I encountered the same problem. Thanks fabricator4, I have solved the problem by the same method above. Here I give some supplement. In my notebook, the excpetions is threw by gspca_main module. So I removed the gspca_main module too, then the installation succeeded. – Miles Oct 4 '12 at 13:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.