I've just installed 10.04 LTS using the Windows installer. The system hangs during boot; the splash screen is frozen and it accepts neither Ctrl+Alt+F2 nor Ctrl+Alt+Del, only a hard reset. (I'm a linux noob.)

When I edit the default Grub boot option to omit quiet splash, it gets to the point saying

* setting sensors limit                                        [OK]

and there it stays.

I can only get to the desktop using the Grub recovery boot option, of course with a lower resolution (800x600) but everything else seems to work fine.

As I said, this is a new install. The only thing I've done is to use the Update Manager to get everything up to date, and activate the newest Nvidia driver using the "Hardware drivers" window.

I had a similar problem when I installed 9.04 a year ago, and at that time posted this question with an answer that worked - this doesn't work with 10.04. Running nvidia-xconfig to create a new xorg.conf didn't fix it either (while in Recovery boot).

The "Hardware Drivers" window just states NVIDIA accelerated graphics driver (version current) [Recommended]. I tried Jonathon's tip about uninstalling the driver and removing the conf file, to see if it can reboot in the normal mode but it just came back into recovery mode. /etc/X11/xorg.conf doesn't exist.

I don't know the exact version of the Nvidia driver. The "Hardware Drivers" window just states NVIDIA accelerated graphics driver (version current) [Recommended]. Also, There is no /etc/X11/xorg.conf, but there is a xorg.conf.failsafe which doesn't say much.
This question mentions nvidia-96. Would that be relevant in my case?

Update 2:
As per Jorge's answer, I've now installed nvidia-glx-185 but afterward nvidia-xconfig doesn't exist (sudo: nvidia-xconfig: command not found). There is still no /etc/X11/xorg.conf file. However, I rebooted anyway and the normal mode (not failsafe) works! Now I got the desktop in 1024x768, which is a huge improvement already. I looked for the xorg.conf after reboot and it still doesn't exist.

Added: Would this be a useful driver? I tried downloading it but instead of a save-as dialog I got a looong page full of php or similar...

Update 3:
I tried Jorge's suggestion of nvidia-glx-185 but didn't manage to get it into 1280x1024. I then tried the version 260.19.29 linked above, but that quickly became very complicated and I ended up somehow breaking my installation (and my Windows boot as well, but I realize it's my own fault). I've now gone away from a Wubi installation and I'm writing this on a brand-new 10.10 installation on a real partition.
So, let's start over: Should I install the nvidia-glx-185 again, and then what?

  • Can you add what version of the driver you are using? For that card it should be 185.18.36-something-something. Dec 30, 2010 at 18:57
  • As Jorge says, check the driver version. As a workaround I'd remove any installed nvidia drivers (e.g. nvidia-current), sudo rm /etc/X11/xorg.conf and reboot so at least the system is usable.
    – Jonathon
    Dec 30, 2010 at 19:13
  • If you just installed the 10.04, how about trying for the 10.10 which solves many video related problems. Do you have good internet connection or is the lack of it why you did not test the 10.10? Dec 30, 2010 at 19:49
  • 1
    @cyrex I already tried 10.10 yesterday with exact same results. I am trying 10.04 now because I was hoping the LTS version would be more stable in this regard. Since it seems to be the same, I think it doesn't matter if I install 10.10 now and fix that, or just fix the 10.04 I have now. Dec 30, 2010 at 20:13
  • 1
    @torbengb As of Update 3 is your system booting to the desktop or are you still having to go into Recovery mode? If you can get to the desktop normally does System->Administration->Hardware Drivers (System->Administration->Additional Drivers on 10.10) show the Nvidia driver as being activated?
    – Manzabar
    Jan 6, 2011 at 22:27

6 Answers 6


I spent some time googling this card and it appears that you need to be using the Nvidia 185 driver. Install it first

sudo apt-get install nvidia-glx-185

and generate the /etc/X11/xorg.conf file

sudo nvidia-xconfig

Then reboot, that should at least get the card working.

Update your question with what happens then we'll move on to setting the resolution.

  • Okay, hit me with the next step :-) I've written update 2 and update 3 in my question. Jan 3, 2011 at 19:38
  • given my update#3 above, would you recommend I try these steps on my new installation? uluga.ubuntuforums.org/showpost.php?p=10252117&postcount=7 Jan 5, 2011 at 13:16
  • @torben Worth a shot, but I've always had it just work. Sorry I don't have time to debug my lone-nvidia machine during the work week to try to help figure it out right now. Jan 5, 2011 at 14:55
  • I understand and I'm thankful for the time you've already invested. Thank you! I'll read up on what other people have been trying, then likely try this. Jan 5, 2011 at 15:18

If I understand your question correctly, you have a problem with setting your monitor to its native resolution.

I have faced similar problems with my monitor.

Refer to my answer, How to set the monitor to its native resolution which is not listed in the resolutions list?

You need to modify steps on monitor resolution you want, like step 1 - cvt 1280 1024

Better try it with some lower resolution first, try till step 6 if everything is ok go to step 6 else simply logout or reboot and your last resolution will be back.

  • Thank you! I followed the directions in the other answer, with modifications for my desired resolution. This didn't give me full hardware acceleration (who cares) but it worked! I now have 1280x1024! Jan 7, 2011 at 8:21
  • that's cool torbengb, you can file a bug report too in launchpad, its very easy --- $ ubuntu-bug xserver-xorg Jan 12, 2011 at 4:25

I have the same graphic card and I have installed both 10.04 and 10.10 on my system and after installing the latest nvidia driver provided by Ubuntu I have full 1280x1024 @75 on my HP 1702 monitor. I think that that problem is with the native settings of your Monitor i.e. Ubuntu is failing to recognize your monitor properly. You need to let ubuntu to detect your monitor so that it can set the monitor's native resolution properly.

  • Well, I've already tried going to System>Prefs>Monitors and clicking the button "Detect monitors". The monitor remained listed as "Monitor: unknown". I'm reading in other forums that this should "just work" straight out of the box, but something on my machine is somehow nonstandard. Haven't found that grail yet. Jan 7, 2011 at 7:14
  • Long shot: What type of cable is going to the monitor? I've had some strange problems setting resolutions when using DVI cables because because "something" in Ubuntu didn't thing the monitor could do it. When I switched to a good-old-VGA cable, things worked.
    – jwernerny
    Jan 7, 2011 at 13:33

BIOS actually has a lot to do with how your external card works with your motherboard. Installing from NVIDIA may be a pain, but this way you will make sure all configurations and all options are added properly to xorg and you will get that nice nvidia console as well.


Simpler solution:

  1. Select the recommended proprietary NVIDIA driver.
  2. Click Monitors on the Preferences menu.
  3. When the system recommends using the proprietor's setup, just say NO. Selecting the 1280x1024 resolution on the Ubuntu setup works. No 3D maybe, but who needs 3D?
  • 1
    I had already done these steps, but the list of available resolutions did not include 1280x1024 -- it stopped at 1024x768. I did eventually find a permanent solution and it should work for any version - and it provides 3D acceleration as well! Feb 6, 2012 at 19:00

follow Jorge's steps, then try this as your xorg.conf

Section "Screen"  
    Identifier  "Default Screen"  
    DefaultDepth    24  

Section "Module"  
    Load    "glx"  

Section "Device"  
    Identifier  "Default Device"  
    Driver  "nvidia"  
    Option  "NoLogo"    "True"  

If this doesn't work try Load "glx-185" instead of Load "glx" - my card works with the nvidia latest, not sure if it's a different module name for the 185 driver or not. I would think not.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .