Right now I have an embedded terminal that occupies the bottom 100 or so pixels of my screen. This is super convenient for me, but unfortunately, whenever I maximize a window, it of course covers up the terminal.

Is there any way to make an application when it maximizes, to only take up the desktop area that does not include the very bottom of the screen where the terminal is? Also, it would be very nice to prevent any window, even those not maximized from entering this part of the screen.

If anyone knows how to make this happen, I would greatly appreciate it.


Parts of this answer comes from: I'd like to prevent maximize from covering one third of the screen

Maximumize may be useful for that case instead of Maximize. Which is included in the CompizConfig Settings Manager and will "Maximumize windows (resize them to fit the available screenspace)"

In your case, Maximumize will fit the window's size in order to use the maximum available screen space in the active work space and this way, windows in screen containing the pidgin, conky, and other window-like applications will be dodged by the Maximumized window.

Maximumize comes from the compiz-fusion-plugins-extra package.

Good luck!

BTW: You may need to set your own key bindings in order to make this work. I used [Alt]+M and it works fine for me.

enter image description here

enter image description here

|improve this answer|||||

You can enable Window rules plugin in CCSM

enter image description here

In the 'Above' match add the terminal application you are using

enter image description here

This will keep the terminal always on top of any other window. You can also adjust window sizes from there.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.