26

I am using youtube-dl to download some videos from youtube. But when I write:

youtube-dl http://www.youtube.com/watch?v=rn_YodiJO6k

I get:

[youtube] Setting language
[youtube] rn_YodiJO6k: Downloading video webpage
[youtube] rn_YodiJO6k: Downloading video info webpage
[youtube] rn_YodiJO6k: Extracting video information

ERROR: unable to download video

What am I doing wrong?

5
33

Same question was asked on unix.stackexchange.com.

Youtube changed something to make it incompatible with youtube-dl, it's been fixed in the latest version. Use the following to update youtube-dl until the package system gets the updated version:

sudo youtube-dl -U

Update

As noted by sup in the comments youtube-dl is patched in Ubuntu to disable the --update option because of security concerns (the bugreport is here). It is also argued in the bugreport that youtube-dl is a moving target, so the version in the repositories is often out of date. This makes easy upgrade a necessity.

Easy upgrade is still possible with e.g. pip. Install like this (you may want to uninstall old versions of youtube-dl first):

sudo pip install youtube_dl

Upgrading can now be done with:

sudo pip install --upgrade youtube_dl

As documented on the youtube-dl download page. Note that similar security concerns are attached to this method as well.

3
  • 1
    This no longer work: bugs.launchpad.net/ubuntu/+source/youtube-dl/+bug/1063469 Install a new version from upstream: sudo wget https://yt-dl.org/downloads/2013.11.07/youtube-dl -O /usr/local/bin/youtube-dl sudo chmod a+x /usr/local/bin/youtube-dl (info from here: rg3.github.io/youtube-dl/download.html )
    – sup
    Nov 7 '13 at 21:41
  • 1
    @sup: I have added a pip alternative which is almost as convenient.
    – Thor
    Nov 8 '13 at 10:39
  • Cool, only it already is disabled, I edit your answer to reflect it.
    – sup
    Nov 8 '13 at 21:03
6

For me the following lines worked:

sudo apt-get remove -y youtube-dl
wget -O - https://yt-dl.org/latest/youtube-dl | sudo tee /usr/local/bin/youtube-dl > /dev/null
sudo chmod a+x /usr/local/bin/youtube-dl
hash -r
1
  • Adding the pip install bin folder to the path could also help.
    – Timo
    Dec 25 '20 at 21:34
-6

You have to put double quotes (") before and after the URL of the video to make it work. I don't think it's a bug.

For example:

youtube-dl "<video-URL>"
1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.