I'm trying to install Ubuntu 12.04 with full hard disk encryption. After downloading and installing the Ubuntu live CD, I learned that truecrypt doesn't support full disk encryption on Linux. I also learned that the best way to get "nearly full disk encryption" on Ubuntu is by installing it from the alternate install CD. I tried that, but something is wrong with my CD reader/burner so it doesnt boot up when i insert the cd.

My thought here was to take the .iso that I downloaded on my unencrypted Ubuntu system, use Unetbootin to make the usb drive.

The usb drive used for this is exactly the same brand as one that I know has worked with a previous ubuntu live system on the same computer. I also used unetbootin for that usb, but I created it from windows that time.

The usb stick boots up fine and i get through the first couple of steps in the installation process. However, After a while I get a "box" with the following error message

"Load Installer components from CD"

There was a problem reading data from the CD-ROM. Please make sure it is in the drive. If retrying does not work, you should check the integrity of your CD-ROM.

"Failed to copy file from CD-ROM. Retry?"

Then I can't get any further.

I googled a lot and found this page which seems to tackle this very problem:

I tried to do what it said. After pressing TAB, I wrote:


without quotes because that's what I think is right.

When I press TAB, there already is a text saying:

/ubnkern initrd=/ubninit vga=788 -- quiet

which can be removed. I have tried to both delete the text before the -- and just inserting cdrom-detect/try-usb=true before it.

Any idea of what can be wrong? I would like to do a full system encryption, or as full as it is possible. I don't want to just encrypt my /home folder. Maybe this isn't the easiest way.

I use SanDisk usb sticks. I know there is a problem with U3 launcher on some SanDisks, but I never had to remove U3 before from similar disks, and the alternate install does boot up, so I dont think using U3 removal would help me.

Any help or indication to an easier way to do this would be appreciated.

  • check your iso image in the usb
    – user91632
    Sep 29 '12 at 15:27

If you are writing the iso from Windows I have found that using Win32 Disk Imager instead of Universal-USB-Installer avoids the cdrom not detected issue.

If you don't do it that way then this workaround works: http://www.mattkowalczyk.com/blog/?p=169


I had a similar issue when installing Ubuntu server from usb where the installation couldn't mount the CD-ROM to install files. The fix that worked for me was as follows.

  1. Open terminal
  2. Plug your usb drive into your pc.
  3. Type sudo fdisk -l
  4. Make note of the usb drive mount point.
  5. Sudo umount (usb drive partition, I.E. /dev/sdb1, /dev/sdc1, etc)
  6. Run sudo dd if=(Img file location) of=(usb drive location, /dev/sdb, do no include the partition number.

Then reboot and boot off the media. You should have no issues.


I believe you should have merged the extra text with the existing line rather than replacing it. So, in the end you would have:

/ubnkern initrd=/ubninit vga=788 cdrom-detect/try-usb=true -- quiet

Note that on my machine, the line looked quite different:

/install/vmlinuz initrd=/install/initrd.gz file=/cdrom/preseed/ubuntu.see vga=788  cdrom-detect/try-usb=true quiet --

Try checking this link on post #2 by spin-dizzy. To get the sd[abcd] of the USB stick, unplug it and re-plug it right before looking at the syslog.

It worked for me after the cdrom-detect/try-usb=true thing didn't.


Check http://cirrus.ucsd.edu/~pierce/fix_ubuntu_usb/.

There is a script that fixes truncated names in the USB.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.