This question already has an answer here:

I watch VLC for a while, then about 15 min. later, it sleeps.

Where can i find the how to disable the screen-saver or how to disable sleep?

marked as duplicate by Evan Carroll, karel, Eric Carvalho, George Udosen, Zanna Apr 29 at 20:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Settings > Power

Go to settings and choose the power option

go to System Settings -> Power -> Suspend when inactive -> don't suspend

  1. Open VLC's preferences.

  2. Select All in Show settings at the bottom of the window.

  3. Pick the Video section at the vertical tree.

  4. Tick the Disable screensaver checkbox.

  5. Save settings.

enter image description here

There are couple of settings that you should check in VLC:

1) Tools --> Preferences --> Show All --> Video --> Disable screensaver

2) Tools --> Preferences --> Show All --> Advanced --> Inhibit the power management daemon during playback

If both of this options are checked, you could try a simple wrapper script which disables the monitor modes that will power down, standby or blank the screen prior to calling VLC:

#!/bin/bash

#Disable modes
/usr/bin/xset -dpms &
/usr/bin/xset s off &

#Open VLC
/usr/bin/vlc "$@"

#Re-enable modes
/usr/bin/xset dpms
/usr/bin/xset s on
exit

Just for one session

     sudo service sleepd stop

in kubuntu you can click on battery icon at left-bottom corner and then click on wrench icon again at left-bottom corner of popped window.

The Configure-KDE Control Module will be opened,there you can change suspend status or other settings like what happen when you close your lid even when system is on battery or it is plugged in.

hope it can be useful.

Not the answer you're looking for? Browse other questions tagged or ask your own question.