problem solved by updating from 12.04 to 12.10.

System settings/sound does not open, freezes and I have to force close. Speaker symbol with volume control does not open scroll-down menu, and there is no sounds. Many people have problems with Hudson Azalia in Ubuntu, but I found no working solution.

I don't really understand much of this, but here are some more details:

aplay -l  :

**** List of PLAYBACK Hardware Devices ****

(after running this one, it starts some kind of process that doesn't get any results, and doesn't stop, terminal has to be shut down)

 lspci -vnn | grep -iA5 audio:

00:01.1 Audio device [0403]: Advanced Micro Devices [AMD] nee ATI Device [1002:9902]
    Subsystem: Hewlett-Packard Company Device [103c:184c]
    Flags: bus master, fast devsel, latency 0, IRQ 53
    Memory at f0444000 (32-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
00:14.2 Audio device [0403]: Advanced Micro Devices [AMD] Hudson Azalia Controller [1022:780d] (rev 01)
    Subsystem: Hewlett-Packard Company Device [103c:184c]
    Flags: bus master, slow devsel, latency 32, IRQ 54
    Memory at f0440000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel

It seems to me that I'm currently running hda Intel drivers on my AMD Hudson Azalia soundcard. I can't see what drivers this soundcard uses.

Update: I've noticed after some more using, that any program, asked to play a sound of any kind, instantly freezes. also the part of all settings that has anything to do with sound, doesn't exist. aplay -l returns a empty list, my standard vollumecontroll just isn't there, and Rhythmbox and Banshee both freezes on startup!

Ive installed pretty much every pakage I can find in the Software Center that has anything to do with sound, and nothing works! Would really appreciate some help with this!

Update: Ive tried to fresh install the Ubuntu 12.10 Beta 2, hoping it's exstended suport for newer hardware would solve my problems, and it did, kind of. I can now hear the beutifull login-sound! only the screen stays black. Not comand-line black, more, shut-off black. there is nothing. the fan and the small indicatorlight on my power-on button are the only things telling me the computer is at all turned after the login-sound is played on 12.10.

So I went back to 12.04, and this time around, I got an EDD information missing error, and it will only boot from the live cd (or USB-disk in this case), and when I do start it with the live USB, everything conected to sound is missing, once again. When I turn of the computer there is always a message telling me that Gnome-settings-deamon is not responding, and must be force -closed. I find thiss odd, since ubuntu is using Unity by default? (I have not yet installed gnome, as my entire system is cripled) It seems the whole sound-settings part of the system went missing, so I thought it might be something wrong with the live-image I used to create the USB-disk. Dowloaded a new one, installed again, no success. same EDD error, same problem.

Just to try if ANY Linux distro could work on my machine, I installed Fedora 17, works like a charm strait out of the box. only problem is I dont like fedora, I dont understand it, I cant even install applications on it, so I want back to Ubuntu, where I belong. But I cant fix this error.

booting with the arguments edd=on and nolapic and also removing quiet splash, I recieved, among many others, these errors:

'unlink after IRQ...probably using the wrong IRQ'

'PCI INTA -> Link [LNKB]->GSI 11 (level, low) -> IRQ 11'

Begin: Mounting root file system......[50.709152]r8169 0000:05:00.0:PCI INTA -> RTL8195e at 0xf8436000, 28:92:4a:43:37:2a XID 00c00000 IRQ 11

unable to enumerate USB device on port 3 Gave up waiting for root device. Coomon problems: Boot args (cat /proc/cmdline) rootdelay root Missing modules (cat /proc/modules; ls /dev)

2 Answers 2


After much searching, this is the only post I have found with my exact problem. I have tried many fixes and I have not solved it entirely, but I was able to make some headway with this:

sudo apt-get autoremove pulseaudio


sudo apt-get install gnome-alsamixer

I did lose the volume icon in the system tray and I still don't have sound, but the system no longer freezes when trying to produce sound or access sound settings. Also, I no longer get the Gnome-settings-daemon not responding message/force close upon shut down.

I will post more if I learn more.


Seems like an IRQ problem to me. I don't have that soundcard, but I can tell you where you'd put the settings.

These are kernel parameters, which are like command line parameters for programs, only that they are for the kernel.

There are two methods to set them:

Temporarily, just for this boot process

After you turned on the computer, select Ubuntu in the GRUB boot menu, but don't press enter - instead, press e. You can edit the kernel parameters there. Look for the words quiet splash and write edd=on nolapic instead of them. Press F10 to boot after you made these changes.

  • quiet splash suppresses boot messages, it doesn't hurt to delete them for this time to see everything
  • nolapic disables the local APIC probing.
  • edd=on enables BIOS Enhanced Disk Drive calls. I'm not sure if this would have anything to do with your problems


If these options solved your sound problems, set them permanently: Edit grub.cfg

sudo nano /etc/default/grub

And change the line



GRUB_CMDLINE_LINUX="edd=on nolapic"

Update grub:

sudo update-grub

and reboot. If you press e again, there parameters should already be there.

  • Thanks for your help Phoibos! Unfortunatly it did not solve my problems, but I think you're onto something with the IRQ, as I was given quite a few errors including this word/abbreviation! I updated the original post with a few error messages, but I copying with pen and paper here, there must be a better way to do this! is there a file that saves pre-boot errors in ubuntu that I can paste from to this site? How do I solve IRQ problems? Oct 16, 2012 at 18:08
  • Hm, maybe you could boot Fedora again and look at the kernel parameters with which it booted. Boot Fedora and enter cat /proc/cmdline.
    – phoibos
    Oct 17, 2012 at 9:47
  • ah, unfortunatly, when I discovered I dont like Fedora, I replaced it with an Debian installation, which doesn't boot...But I did not make any changes at all in fedora, all standard. Assuming the installation does not add specific arguments depending on hardware? I should be able to find fedoras standard arguments on the internet and try them! a quick search provided me with: rhgb quiet initrd ubuntu had quiet splash, here its quiet initrd, same thing? well, Ill try everything I can find, and let you know in a bit! Oct 17, 2012 at 19:34
  • nope, did not change a thing, sorry for double-posting Oct 17, 2012 at 19:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .