I have just started Linux. I have a SBC(Atom processor) on which I have installed Ubuntu 12.04 and now I am trying to install Fortran IDE.

For which I have learnt that I need to install OpenJDK first, then Eclipse Juno and at last the Phortran plugin for Eclipse.

I have no Internet access so I had follow the below steps for manual installation.

  1. First download the eclipse tar.gz package (downloaded: eclipse-parallel-juno-linux-gtk.tar).

  2. Then right-click the eclipse tar.gz and choose the extract here option to extract the tar.gz package.You can also use the command line to extract the tar.gz package.

    # tar xzf eclipse-cpp-juno-linux-gtk.tar.gz
  3. Move to /opt/ folder.

    # mv eclipse /opt/

    Use sudo if the above command gives permission denied message.

    # sudo mv eclipse /opt/
  4. Create a desktop file and place it into /usr/share/applications

    # sudo gedit /usr/share/applications/eclipse.desktop            

    and copy the following to the eclipse.desktop file

    [Desktop Entry]
    Comment=Integrated Development Environment
  5. Create a symlink in /usr/local/bin using

    # cd /usr/local/bin
    # sudo ln -s /opt/eclipse/eclipse
  6. Now its the time to launch eclipse.

    # /opt/eclipse/eclipse  -clean  &       

Now at step 5, when I type the command sudo ln -s /opt/eclipse/eclipse , I get an this error message:

ln: Failed to create symbolic link './eclipse': File exists.

Please help me in resolving this.


Issue the following commands:

sudo rm /usr/local/bin/eclipse  
sudo ln -s /opt/eclipse/eclipse /usr/local/bin/eclipse

sudo /opt/eclipse/eclipse -clean & 

If you have errors after these commands check this question (answer 2) askubuntu.com/questions/26632/how-to-install-eclipse

  • The first command deletes the actual eclipse binary, doesn't it? I think you meant sudo rm /usr/local/bin/eclipse. Then use sudo ln -s /opt/eclipse/eclipse eclipse. – phoibos Sep 27 '12 at 11:13
  • hi kamil & phoibos just tried as you have said, gives me same error msg: "ln: failed to create symbolic link 'eclipse': Fileexists" – VRU Sep 27 '12 at 13:07
  • Okay, just tried the command "sudo rm /usr/local/bin/eclipse" and it pop'd error msg: "rm: cannot remove '/usr/local/bin/eclipse': No such file or directory" – VRU Sep 27 '12 at 13:17
  • it said "eclipse:" – VRU Sep 27 '12 at 13:20
  • it gives me same error "ln: failed to create symbolic link 'eclipse': File exists" – VRU Sep 27 '12 at 13:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.