4

Summary:

How do I remove folders mounted via bind or bindfs in /etc/fstab from appearing as devices in nautilus left column, the "places" view?

detailed:

Hello,

I mount various directories from my data partition via bind in /etc/fstab in my home directory, eg like this:

 #using bind:
 /mnt/sda5/bazon/Musik   /home/Bazon/Musik   none   bind,user   0 0
#or using bindfs
bindfs#/mnt/sda5/tobi/Downloads /home/tobi/Downloads fuse user 0 0

(Background: /dev/sda5 mounted to /mnt/sda5 is my old home partition, but I do not want to mount it as a home partition, as I always have at least 2 Linuxes on the computer ...)

That works well, but since 12.10 every one of those items is listed in Nautilus in the left column under "Devices". (Where normally USB drives appear, etc.) This is a waste of space (as I have many of such mounts...) and so I would like to have these mounts hidden, just as it was before in 12.04. How can I do that?

Thanks!

  • Are you using Nautilus 3.6 from the Gnome PPA? 12.10 uses the same Nautilus that is in 12.04, so you should not have this problem if you are using the right version of Nautilus. – RolandiXor Sep 27 '12 at 15:38
  • It's nautilus 3.4.2 from the official ubuntu repositories, no other PPA is used. So maybe something else caused it? – Bazon Sep 28 '12 at 16:24
5

if you mount the partition somewhere other than /media or /home and symlink to it, the nautilus buttons would disappear

  • 1
    Years ago, I tried that before and ran into some problems because some programs didn't recognize the symlinks as folders. Because of your answer, I tried it again and don't have problems so far... and I should add: mounting to /mnt isn't displayed in nautilus either. – Bazon Sep 28 '12 at 16:25
  • i have the same problem now in quantal but not in precise. Why I have to mount my Music partition not in home? in precise there wasn't this problem! – flux Sep 29 '12 at 13:56
  • if you read the question you will notice that this problem is related to quantal (12.10) when he said "That works well, but since 12.10 every one of those items is listed in Nautilus in the left column under "Devices"" – user91632 Sep 29 '12 at 14:56
2

My workaround is to remove "read for all" attribute from /etc/fstab. Open a terminal (Ctrl+Alt+T) and type:

sudo chmod a-r /etc/fstab

Then you should restart.

2

Add comment=x-gvfs-hide to mount options (4th column) in /etc/fstab. This will tell your file manager to hide that mount.

In your case:

bindfs#/mnt/sda5/tobi/Downloads  /home/tobi/Downloads  fuse  user,comment=x-gvfs-hide  0  0
  • This appears to work in Caja on Ubuntu-Mate as well. – Alecz Dec 6 '17 at 0:27

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.