I have problems with getting an Asus PCE-N53 11n N600 PCI-E Adapter card to work on my desktop computer.

As far as I can tell no drivers are installed for the card. I know I can manually download the drivers directly from Asus, but I would rather not go that route.

If there are anyone that knows about any packages or other things I can do to make this work would be much appreciated.

Some systems details:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 12.04.1 LTS
Release:    12.04
Codename:   precise

$ sudo lshw -C network
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 06
       serial: d4:3d:7e:03:b9:1d
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168e-3_0.0.4 03/27/12 ip= latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:43 ioport:d000(size=256) memory:f2104000-f2104fff memory:f2100000-f2103fff
 *-network UNCLAIMED
       description: Network controller
       product: Ralink corp.
       vendor: Ralink corp.
       physical id: 0
       bus info: pci@0000:04:00.0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:f7100000-f710ffff

$ lsmod
Module                  Size  Used by
nvidia              12319264  51 
vesafb                 13844  1 
snd_hda_codec_hdmi     32474  1 
joydev                 17693  0 
bnep                   18281  2 
rfcomm                 47604  0 
bluetooth             180104  10 bnep,rfcomm
snd_hda_codec_realtek   224173  1 
snd_seq_midi           13324  0 
ppdev                  17113  0 
snd_rawmidi            30748  1 snd_seq_midi
usbhid                 47199  0 
hid                    99559  1 usbhid
nouveau               774641  0 
parport_pc             32866  1 
snd_hda_intel          33773  5 
ttm                    76949  1 nouveau
snd_hda_codec         127706  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
drm_kms_helper         46978  1 nouveau
drm                   242038  3 nouveau,ttm,drm_kms_helper
snd_seq_midi_event     14899  1 snd_seq_midi
snd_hwdep              13668  1 snd_hda_codec
snd_seq                61896  2 snd_seq_midi,snd_seq_midi_event
i2c_algo_bit           13423  1 nouveau
mxm_wmi                12979  1 nouveau
wmi                    19256  1 mxm_wmi
mac_hid                13253  0 
snd_pcm                97188  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
psmouse                97362  0 
video                  19596  1 nouveau
snd_timer              29990  2 snd_seq,snd_pcm
snd_seq_device         14540  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    78855  20 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_rawmidi,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_pcm,snd_timer,snd_seq_device
serio_raw              13211  0 
soundcore              15091  1 snd
snd_page_alloc         18529  2 snd_hda_intel,snd_pcm
mei                    41616  0 
lp                     17799  0 
parport                46562  3 ppdev,parport_pc,lp
r8169                  62099  0 

I just ended up compiling the driver myself. Not what I would have wanted, but hopefully this will be fixed in the next version of Ubuntu.

I someone else has the same problem here is what worked for me:

Install build-essentials

sudo apt-get install build-essential

Download the driver from Asus. I found them here: http://www.asus.com/Networks/Wireless_Adapters/PCEN53/

Unpack the downloaded .zip file. The download comes with a lot of instructions for what you need to do. Most of them turn out to not be required.

Enter the directory where you unpacked the zip and unpack the driver code.

tar -jxvf DPO_GPL_RT5592STA_LinuxSTA_v2.6.0.0_20120326.tar.bz2

Enter the new directory and start make


This runs for a while and then fails due to a missing /tftpboot directory. This does not seem to be relevant since the correct file is made anyway.

Now install the driver.

sudo make install

The installation instructions tells you to edit a /etc/rc.d/rc.local file. Since I didn't have neither the file or directory I just skipped this step and rebooted.

After the reboot everything seems to work. Ubuntu automatically found the card and it is what I am using now. Since I have only been using it for 10 minutes I don't know how stable it is but hopefully it will be ok.

Note: I found that I had to have my Ethernet unplugged and then restart Ubuntu for this to take. Otherwise works great.

  • No need to reboot - just sudo modprobe the device. i seem to remember it being sudo modprobe ra5592sta – yarbelk Feb 26 '13 at 5:00
  • 2
    do we have support for this card by default in Ubuntu 13.04? – lucassp Apr 5 '13 at 11:06
  • Any news about support in Ubuntu 13.10? – lucassp Oct 13 '13 at 12:45
  • trusty help?? need step by step. – mercurymod May 20 '14 at 10:27

I was having the same problem and emailed Asus about the should support the 3.x kernel and they wrote back saying that they have forwarded the email the their tech team.

Anyway I was doing a bit more research into the matter and found a post on the Arch Linux forums. A user there posted a patch to get it working on a 3.x Linux kernel, I have tested it and so far all is functional with a couple of hours of light usage.

Here is the link to the patch file, just apply it to the Linux drivers from the Asus website.

  • This one worked for me, just had to read through the whole thread – Ryan Stull Aug 7 '15 at 8:59

When I followed the instructions here, the driver installed and allowed me to connect to my router for about two seconds then I got a kernel panic and had to do a hard reset to recover.

Here are the differences in the steps that I took and it worked like a charm:

Downloaded the drivers from ASUS's website (did not use from CD) even though it looked like the same version.

I used sudo make (instead of just make) and it compiled without the errors mentioned above. (not sure if this matters but when I ran just make, it error-ed out at the end. I ran sudo make and it completed.

I then ran sudo make install. After that completed, I rebooted and it's been stable after a few reboots.

Hope this helps any in the same situation.


This worked and was an excellent guide when I was running 11.10. But now that I've upgraded to 12.10, activating the card leads to a complete lock-up within seconds.

$ uname -a
Linux Zubzero 3.5.0-18-generic #29-Ubuntu SMP Fri Oct 19 10:26:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 12.10
Release:    12.10
Codename:   quantal

lshw output:

       description: Trådlöst gränssnitt
       product: Ralink corp.
       vendor: Ralink corp.
       physical id: 0
       bus info: pci@0000:09:00.0
       logical name: ra0
       version: 00
       serialnumber: 10:bf:48:xx:xx:xx
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=RALINK WLAN latency=0 multicast=yes wireless=Ralink STA
       resources: irq:16 memory:f4400000-f440ffff
  • Yes, I have the same problem. It freezes for me on 12.10 as well. I haven't had time to investigate further yet. Since Linux is supposed to be supported it might be worth while sending a support request to Asus. – oyse Dec 4 '12 at 19:48
  • I have registered a support ticket with Asus now and will report back if they say anything usefull. – oyse Dec 4 '12 at 20:03
  • 1
    I got a response from Asus saying only kernel version 2.6.x is supported and that newer kernel version might be incompatible and that they do not have any timeline for when a new driver will released. In other words the solution is probably to downgrade Ubuntu version (not something I am willing to do) or get a new wireless card :( – oyse Dec 9 '12 at 15:58

I was able to get the driver working on Ubuntu 13.10 by following the directions at this link.

The essential parts that I found to get it working required

  1. patching the driver code to compile on a 3.x kernel (specifically 3.11.x )
  2. use sudo make instead of make
  3. (optional) sudo modprobe rt5592sta to load the driver without the need for a reboot.
  • 1
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Eric Carvalho Oct 21 '13 at 0:23

protected by Seth Mar 20 '14 at 16:23

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.