In earlier Ubuntu releases (As far as I remember Natty had it) we were asked for password while trying to mount the drive using Nautilus. But in Ubuntu 12.04 (also in 11.10) it is removed. But I want to re-enable that feature.

Question is: How can I re-enable that feature i.e being asked for mounting drive?

  • An easy workaround is to just encrypt the drive(s). I have multiple extra drives, internal and external. All are encrypted. If a drive fails or I give it away I don't need to worry about my data ever being recovered. (I don't think this is exactly what you are asking for so posting as a comment...) – Tom Brossman Sep 26 '12 at 20:01
  • I'm not very concerned with the data. I was just wanted to enable that feature. I can disable mounting of some drive from a user, to whom I've given my computer for a while. thank you for the comment. I may need that too. – Anwar Sep 26 '12 at 20:07

To re-enable that feature, you have to change the default policy. Follow this procedure:

  1. Open terminal with Ctrl-Alt-T keyboard shortcut.

  2. Type the command below ( you can copy and paste at the terminal ) and hit Enter.

    gksu gedit /var/lib/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla
  3. In the first section, under the heading of [Mounting, checking, etc. of internal drives] There will be a line with ResultActive=yes. Change the yes to auth_admin. The section after modification will look like this

    [Mounting, checking, etc. of internal drives]

    Save the file by pressing Ctrl-S and Exit gedit.

The feature is now activated.

  • @nitstorm Thanks for the edit. That was crucial – Anwar Sep 26 '12 at 19:33
  • Most welcome :) – Nitin Venkatesh Sep 26 '12 at 19:34

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.