My situation is the same that is addressed here

I tried to install Ubuntu 12.04 from the Live CD alongside my current Windows 7. I have to switch my BIOS to legacy mode in order to boot from CD. If I were to do a normal installation and remain in legacy mode, the BIOS will display "operating system not found". If I switch back then the BIOS just boots to windows.

To solve the problem, I tried following the steps in the previous two articles. My drive is partitioned as:

sda1 FAT32 Location of Windows EFI files (flagged as boot in Ubuntu install)
sda2 unknown
sda3 NFTS Windows C:
sda4 ext4 Ubuntu root
sda5 swap
sda6 ext4 Ubuntu home

I was a little confused by the requirement in the second article to "be careful to install Grub bootloader in /dev/sda3"

In my case, the relevant partition is sda1. I have tried three things: setting the sda1 mount point as /boot, as /boot/efi, and as the special reserved grub partition. In each install I indicated that grub should be installed in sda1.

After each install I reboot to the live CD and look in the sda1. I see EFI/Boot and EFI/Windows, but no EFI/Ubuntu and consequently no grubx64.efi.

I understand the recommended procedure of moving grubx64.efi into the EFI/Boot directory and replacing the present bootx64.efi file, but I see no grubx64.efi and I don't know where it should be.


2 Answers 2


Broadly speaking you have three options:

  • Manually install an EFI boot loader for Linux. This is the easiest solution in principle, but it can be tricky to get working in practice.
  • Re-install Ubuntu, but figure out how to get your computer to boot the installer in EFI mode rather than in BIOS mode. Chances are this can be done by fiddling with options in your firmware, but the details vary so much from one system to another that it's hard to give simple and definitive advice.
  • Wipe your hard disk, set your firmware to BIOS mode, and install both Windows and Linux in that mode. This will be a pain to do, but in some cases people in your situation end up resorting to it in the end.

To get started with the first option, I recommend using a USB flash drive. Partition it with GPT and create an EFI System Partition (ESP) on it. (An ESP has its "boot flag" set in GParted or has a partition type code of EF00 in gdisk. In either case, it uses a FAT filesystem -- preferably FAT32 -- and it's usually 100-500 MiB in size.) On the ESP, create an EFI/BOOT directory and place your boot loader program there with the name bootx64.efi. For instance, you could put ELILO there. In the case of ELILO, you'd also need to copy a Linux kernel and initial RAM disk to the drive and create a configuration file. The point of all this is that you can mess with the USB flash drive on another computer, stick it into your target system, and tell the firmware to boot from the USB drive in EFI mode. If it doesn't work, you can fiddle with it and try again. Repeat that until it does work. Once you get something that will boot your Linux installation, you can copy those files over to the ESP on your hard disk (/dev/sda1) and use the efibootmgr program to register the boot loader with your firmware.


As you can see in my post: Booting the liveCD/USB in EFI mode fails on Samsung Tablet XE700T1A

I am currently having hard times working with uefi. I think what I did today could solve your problem.

You will have to first install win7, then boot on ubuntu-secure-remix in BIOS mode.

During install remember to select "something else" when asked about location. In the partition manager instruct installer to use /dev/sda1 as /boot/efi. And whatever other partitions you need (I didn't use a separate /boot partition, but it could work I think).

Select /dev/sda as grub device.

  • At install end, tell that you want to "keep trying ubuntu".
  • Open a terminal and issue the command "sudo boot-repair".
  • Say yes when boot-repair wants to update to latest ppa version.
  • You should see a message "EFI detected", then you can go on.
  • Select advanced settings
  • Select reinstall grub
  • On grub tab, select 'use separate /boot/efi partition /dev/sda1'.
  • Boot-repair will ask you to issue some commands in the console, do as you are told to.
  • when boot repair exits it gives you an url for your boot-info, note it (and send it here)
  • Then you can reboot.

This may work for you. But if you get the blank/purple screen problem, then you are screwed as I am, and we can merge our posts.



You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .