I have a Desktop which runs on Windows XP and a laptop which runs in Ubuntu 12.04.

Recently I have set up a wireless router in order to be able to access internet on my laptop through wifi. The laptop connects to the wifi at ease, but is unable to transfer any data. Only when I switch on my laptop for the first time, it is able to transfer some data for just few minutes, after which it even fails to ping the router.

Ping to router shows: "ping: sendmsg: No buffer space available", but the wifi still shows to be connected.

Please help!

  • @Anuj - the way this site works is by constantly refining your question with relevant information and replies. Please can you edit your question and add the relevant comments above and delete your comments. Thanks. – fossfreedom Sep 27 '12 at 16:43
  • @kamil - similar comment above - post an answer and edit your answer as you "converse" with the OP. Thanks. – fossfreedom Sep 27 '12 at 16:44
  • What are the results of running the command ifconfig ? – NGRhodes Jun 9 '14 at 11:03
  1. Maybe it's a duplicate IP address?

  2. It maybe another software affecting your connection, try to stop Ubuntu firewall.

    sudo service ufw stop

  3. Check the log.

    cat /var/log/syslog | less

  4. Try to tune the buffer size.

    echo 83886080 |sudo tee /proc/sys/net/core/wmem_max

  5. The problem is in the router.

  • I just reset and reconfigured by router, and it seem to work fine. – Anuj Sep 28 '12 at 20:47
  • still working fine? – user91632 Sep 29 '12 at 5:33

Myself and many others (according to my Google searches) are having this same problem with Ubuntu 11.10, whereas for me also I never had any trouble with network drivers in 10.x or even 11.04.

EDIT: Cause of problem NOT resolved, after all :'(. The following might still be involved in some way, so I'll leave it here for others to reference. But it turned out NOT to solve the problem. Neither did reverting to a 2.6.x kernel.

My system is using the r8169 driver for my Realtek 8168 chip Ethernet port (on the motherboard in my case. Note: 8168 -- not 8169!)

I finally got onto this issue when I found this post. I quickly confirmed that my 8168 card was using the r8169 driver by running ...

sudo lshw -class network

..., which takes a while -- just be patient. :-)

You can see the driver being used in the configuration: line ... Example: ...

configuration: autonegotiation=on broadcast=yes driver=r8168 driverversion=8.026.00-NAPI ...

Then I mostly followed the instructions in this post to install and activate the correct driver, changing specific paths as required to match my system. Note that the driver download site does not mention the v3.x.x kernel (only 2.4.x and 2.6.x) But it works just fine anyway.

If you have only one network interface, then you should be all set by this stage.

Unfortunately, it wasn't quite that simple for me, because I also had a second card installed, which did have an actual 8169 chip on it! :-/ So, I couldn't just leave the r8169 driver disabled.

To fix this, I renamed the /lib/module/your-kernel-version/drivers/net/r8169.bak file (the autorun.sh driver installer script renamed it) back to r8169.ko and edited /etc/modules as follows ...

# /etc/modules: kernel modules to load at boot time.
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.


... [last two lines added] hoping that this would force the modules to be loaded in that same order, thus avoiding modprobe picking up the r8169 driver for the wrong card. It worked!

To the OP ... I'm updating this for the benefit of other people searching for a solution, because it comes up pretty high in Google results. Hope you don't mind.

  • Uhmm, thank you for the advice. Actually I use wimax interface on which I experience the problems. The driver which is used is i2400m with the firmware=i6050-fw-usb-1.5.sbcf. – Oleksa Oct 31 '11 at 8:43
  • Yeah ... and I've just discovered that the problem has NOT actually gone away. At this point, I can only believe that there's a kernel fault, above the layer of network driver modules. I read in some other random post that someone else had come to the same conclusion. Their fix was to roll back to 2.6.x kernel. Easier said than done. – gruvin Oct 31 '11 at 22:02
  • Ehmm, you know when I restart NM the issue goes on. Perhaps to try to re-compile NM? I tried but failed due to inconsistent dependencies. – Oleksa Nov 2 '11 at 23:45
  • Well it's very annoying issue. What to do? It appears when I use wimax connection session. – Oleksa Nov 11 '11 at 0:06

I have seen this with a Centrino Ultimate-N 6300 8086:4238 wireless interface (on a Thinkpad X201). As best as I can tell, this is a known bug in the wireless driver or its firmware, probably the same as Bug #836250. I have asked what the message actually means at "What does “ping: sendmsg: No buffer space available” mean?".


  • Since I only get this intermittently, a workaround is to completely reset the wireless network whenever the issue occurs:

    sudo modprobe -r iwlwifi
    sudo modprobe iwlwifi
  • Another possible workaround is to switch your router to 802.11g-only mode (I think the issue only occurs when connecting to an n network)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.