My tablet is Samsung Series 7 Slate (XE700T1A-A02FR (French Language)). It operates an Intel Sandy Bridge architecture. The main issue about this tablet is that it ships with an installed Windows 7 in (U)EFI mode (GPT partition table, etc.), so I'd like to get an EFI dual boot with Ubuntu.

But it seems I can't boot on the liveCD in EFI mode. It starts loading (up to initrd), but I then get a blank (black) screen. I've tried the nomodeset kernel option (as well as removing quiet and splash) with no luck.


I have used the Ubuntu 12.04.1 Desktop ISO (I have read somewhere that it is the only one that can boot in EFI mode).

I'd say this has something to do with UEFI since the LiveCD boots in bios mode but not in efi mode.

Besides, I am not sure my boot info will help, since I can't boot the LiveCD in EFI mode. As a result I can't install ubuntu in EFI mode. So it would be the boot info from the liveCD boot in bios mode. This happens on a ubuntu-12.04.1-desktop-amd64 iso used on a LiveUSB. Live USB was created by dd'ing the iso onto the full disk device (i.e. /dev/sdx no number) of the Flash drive.

I have also tried copying the LiveCD files on a primary GPT partition, but with no luck, I just get the grub shell, no menu, no install option.


I tried today a flash drive created with Ubuntu's Startup Disk Creator and the alternate 12.04.1 64 bit ISO. I get a grub menu in text mode (which meens it did start in efi mode) with install options / test options. But when I start any of these, I simply get a black screen (no cursor, neither mouse nor text-mode cursor). I tried removing the 'quiet' option and adding nomodeset and acpi=off, but it didn't do any good. So this is the same result as for the LiveCD.


I have tried with a version of the secure remix version via usb-creator-gtk. The boot on the USB key has the same symptoms. Boot in EFI mode is impossible (I have menu but whatever entry I choose, I get the blank screen problem). The boot in BIOS mode works, I did the install. Then I used boot-repair to try installing grub-efi and get a system that would boot in efi mode. But I can't boot this system, because the EFI firmware doesn't seem to detect that sda contains a valid efi partition. Here is the resulting boot-info Boot info 1253554


Today, I have reinstalled the pre-shipped version of windows 7, and then installed ubuntu from a secure-remix iso dumped on USB flash drive vie usb-creator-gtk booted in BIOS mode. When install ended, I said "continue testing" then I used boot-repair to try get the bootloader installed.

Now, when I boot the tablet, I get the grub menu, it can chainload windows 7 flawlessly. But when I try to start one of the ubuntu options I get the same old blank screen.

Here is the new boot-info: Boot info 1253927


I tried installing the 3.3 kernel by chrooting a live usb boot (secure remix again) into the installed system.

Same symptoms.

I feel the key to this is that the device's efi firmware (which is EFI v2.0) would expose the graphics hardware in a way that prevents the kernel to initialize it, and thus prevents it from booting (the kernel stops all drive access just after the screen turns kind of very dark purple).

Here is some info on the UEFI firmware as given by rEFInd:

EFI revision: 2.00
Platform: x86_64 (64 bit)
Firmware: American Megatrends 4.635
Screen Output: Graphics Output (UEFI), 800x600


This week end I tried loading the kernel with elilo. Eventhough I didn't have more luck on booting the kernel, elilo gives more info when loading the kernel.

I think the next step is trying to load a kernel with EFI stub directly.

  • Please indicate your Boot-Info URL. Your problem is not due to UEFI, but to graphic driver or kernel problem. I recommend you try other kernel options (nomodeset, acpi=off...) – LovinBuntu Sep 27 '12 at 6:42
  • Thanks for the feedback, I will post my boot info as soon as possible. I'd say this has something to do with UEFI since the liveCD boots in bios mode but not in efi mode. – F.L. Sep 27 '12 at 9:27

** [2012-10-12] **

After some days of despair trying to compile a custom kernel to manage to boot Ubuntu in EFI mode, with no real belief and no success, I tried (again, with no real faith in it) with the new ubuntu 12.10 beta 2 version dumped on a flash drive with usb-creator-gtk.

Et voila !

The Ubuntu-12.10-beta2-amd64 LiveUSB manages to boot in EFI mode ! Install works, and I am left with ... A perfectly booting EFI install of ubuntu !!

I can now use efibootmgr and all. I installed rEFInd to get a nice graphical OS chooser.

I'm so happy !

took me a full month to get it work....

BTW: This answer is posted through my newly working samsung xe700t1a tablet runing Ubuntu 12.10 beta2.

  • I had been ready to fire a gun into my box before this. I love you +1 – im so confused Nov 30 '12 at 20:07

just found my answer from https://help.ubuntu.com/community/UEFI#Converting_Ubuntu_into_EFI_mode

Secure boot is not fully supported yet, so i had to disable it

  • I have tried this already without success, see the entry [2012-10-01] in my question. – F.L. Nov 26 '12 at 0:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.