Possible Duplicate:
How to blacklist kernel modules?

I compiled Ndiswrapper from source. Then installed a wireless windows driver. After that I loaded the Ndiswrapper kernel-module with sudo modprobe ndiswrapper. Now my system stops during boot.

How can I unload the Ndiswrapper kernel-module?

  • Does your systems completely stop at boot? Can you go to the recovery mode? – Anwar Sep 26 '12 at 15:52
  • @Anwar I tried recovery mode, but it stops too. – BuZZ-dEE Sep 26 '12 at 15:58
  • 1
    Check this answer to disable ndiswrapper module temporarily and see the above link to disable it permanently once you get into the system – Anwar Sep 26 '12 at 16:01
  • @Anwar thx adding ndiswrapper.blacklist=yes as boot parameter solved my problem, but it's not necessary to do that permanently. My intention was, how can I do that before boot. On a running system I know how to blacklist a kernel-modul. – BuZZ-dEE Sep 26 '12 at 17:16

You can boot using a Live USB and modify the /etc/modprobe.d/blacklist.conf file.

Just add the module you don't want to load, e.g.

blacklist ieee1394
blacklist ohci1394
blacklist eth1394
blacklist sbp2

You can also blacklist modules from the bootloader.

Simply add modprobe.blacklist=modname1,modname2,modname3 to your bootloader's kernel-line parameter list.

For information on how to edit the boot parameters, go here: How do I add a kernel boot parameter?.

  • Instead of ndiswrapper.blacklist=yes, I could also use modprobe.blacklist=ndiswrapper? – BuZZ-dEE Sep 26 '12 at 17:19
  • 1
    yes, you can use it. – green Sep 26 '12 at 17:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.