2

On my laptop, running 10.10, whenever I plug in a thumb drive Nautilus will add an icon on the desktop and open a file manager window with the drive contents. This does not work for my 250Mb external hard drive: the icon is added on the desktop, but no file manager window pops up. Double clicking on the icon just causes some disk activity (on the system drive) and nothing else. Double clicking another time on the icon the file manager eventually opens. At first I thought this was related to nautilus-elementary, but after removing nothing has changed. How do I even start debugging this?

Update: suggestions below got me curious, so I "Safely removed" the drive, unplugged it and plugged it in again. This time it would open on the first double click (no automagic file manager window yet, anyway). Doing a quick "mount" in a terminal shows my USB drive is mounted as a fuseblock device. I suspect the first ineffective double click could be used to load/start the whole user space filesystem thingie.

Update: from what I can see after a fresh boot the hard disk is mounted as soon as the icon appears on the desktop, the only thing that doesn't work is double-clicking the first time. Right-clicking the drive and chosing "Open" always works the first time, seems like "Open" is not the default double-click action for external drives...

Update: Looks like there are a couple of bugs that could be related:

2

I believe that this is because it is actually an external disk and that Ubuntu is not mounting it automatically. So your first double click is actually telling it to mount. The second telling it to open.

If you would like it to duplicate the behaver of the usb drive, someone else will have to tell you how to set this up or I may find out how to do it and get back to you.

1

I have read that for some types of devices (External Hard-Drives for example) the action of Double clicking on the access in the Desktop it is, for the first time to Mount it. The second Double click is to Open it.

So:

Double Click 1 - Mount the External Unit

Double Click 2 - Open The Mounted Unit.

1

On my system .. also Ubuntu 10.10 though it has been upgraded over time all the way from 9.10. It does not have this behaver. Instead both usb flash drives and usb hard drives get mounted automatically. But I do have a setting enabled in side gconf-editor.

So I would run(in a terminal)
gconf-editor
Which should open a window then go
(not really code but looked better this way)
apps -> nautilus -> preferences
in the window on the right make sure that both of the following are check:
media_automount
media_automount_open

I think this is what I did a wile back to get mine to function this way. If it still doesn't do what you would like it too... I will give you the satisfaction of knowing I will scratch my head.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.