i have Ubuntu 12.04 x64 ISO, i load it on a Fat32 USB. My notebook has a hdd with GPT where i installed Official Win 8 Pro x64 (final versión), I partitioned the whole hdd, previously of win 8 install, and bios is set with UEFI boot. My BIOS notebook doesn't support SECURE UEFI BOOT.

So I boot the notebook from USB and the Grub runs OK showing whether to run Ubuntu live or to install, but neither one neither two works, when I choose then the screen shows black and nothing happen, it doesn't start/loads the install program.

I've try whether to prepare the usb with unetbootin, or just direct copy/paste the files onto the USB. I also have try WUBI, but neither with success, it launch an error when ending.

  • I have the exact same problem on my Toshiba Satellite S50-A. In my case the problem is definitely related to UEFI; if I configure the firmware for "CSM Boot", aka legacy BIOS mode, the USB drive boots normally. The one partial solution that I have found is this: If I disable "Built-in LAN" in the setup utility, the Live USB will boot as expected in UEFI mode. Of course, then the ethernet adapter is completely disabled. In my case, I only use WiFi, so it is an acceptable sacrifice. (Thanks to user oldfred who provided this suggestion in response to [my own question](askubuntu.com/questio
    – ellocogato
    Dec 4 '13 at 20:43

I have successfully achieved dual boot from installation on the primary hard drive with the following configuration and issues:

Hardware: August 2012 build HP Envy DV7 laptop, Windows 8, i5 Ivy Bridge, UEFI/Secure Boot.
Linux: Ubuntu 12.10 x64 ISO.

In UEFI (F10 menu):

  • Disable Secure Boot. I could not achieve boot in any configuration with it on.
  • UEFI boot scheme (not Legacy BIOS). I tried Legacy mode, and can boot from disk, but not from an installation on the hard drive. UEFI flies right by it during boot every way I tried with it on.

In Ubuntu:

  • /Boot=EFI, /=EXT4, /Home=EXT4, SWAP=swap

With this configuration I can boot with user intervention during the boot sequence:

  1. Select F9 Boot options in UEFI (BIOS)
  2. Select the now avialble Ubuntu 12.10 option and procede.
  3. Immediately the Ubuntu boot option screen is now available. Select prefered option and procede.
  4. I'm in.

If anyone following this thread comes up with a way for the Windows UEFI boot loader to recognize the /boot partition automatically, please share. The above method is not that much of a pain, but an automatic boot whence windows recognizes Ubuntu as a boot option would be a somewhat more elegant affair. Also, I would prefer to have Windows handle the primary boot sequence, and not grub, as a personal preference, so I can live with the above until other options are available.


First suggestion ensure that you boot from the device in UEFI mode. With my system when I choose the boot device in BIOS for example via my SSD. The BIOS lists both the drive as port 0 or whatever it is, and then it also list it as Ubuntu. So I have to make sure I select Ubuntu as the boot device.

Also make sure that you have enable UEFI in BIOS. If I do a BIOS reset mine automatically defaults to legacy mode.


Your problem is not related to UEFI, but to graphic drivers or kernel options. Please try booting with kernel options, eg nomodeset. See https://help.ubuntu.com/community/BootOptions

Not the answer you're looking for? Browse other questions tagged or ask your own question.