Fresh install of 12.04.1 LTS x86-64, Sapphire Flex HD6950 video card.

  • I initally booted with one display connected, added the other four, and they all worked (cloned)
  • I can set them to "Multi-display desktop" and get five independent displays, but each has its own Unity bars. (I eventually want to merge four of these into a single work area treated as one display)
  • In pursuit of Xinerama, I set them to "Single Display Desktop (Multi-desktop)", which requires a restart. During the subsequent boot, X fails to start.

Interesting bit from the end of /var/log/Xorg.0.log :

[    14.517] (II) fglrx(4): [uki] DRM interface version 1.0
[    14.517] (II) fglrx(4): [uki] created "fglrx" driver at busid "PCI:1:0:0"
[    14.517] (II) fglrx(4): [uki] added 8192 byte SAREA at 0x2000
[    14.517] (II) fglrx(4): [uki] mapped SAREA 0x2000 to 0x7fb706a97000
[    14.518] (II) fglrx(4): [uki] framebuffer handle = 0x3000
[    14.518] (II) fglrx(4): [uki] added 1 reserved context for kernel
[    14.518] (II) fglrx(4): swlDriScreenInit done
[    14.518] (EE) fglrx(4): Not enough video memory to allocate primary surface (frame buffer).
[    14.518] (II) fglrx(4): Shutdown CMMQS
[    14.518] (II) fglrx(4): [uki] removed 1 reserved context for kernel
[    14.518] (II) fglrx(4): [uki] unmapping 8192 bytes of SAREA 0x2000 at 0x7fb706a97000
[    14.518] (WW) fglrx(4): ***********************************************************
[    14.518] (WW) fglrx(4): * DRI initialization failed                               *

This line in particular drew my attention: fglrx(4): Not enough video memory to allocate primary surface (frame buffer). The card has two gigabytes of memory.

I'm using latest stable driver from AMD (12.8), built .debs with this guide: What is the correct way to install proprietary ATI Catalyst Video Drivers (fglrx) directly from AMD?

Somebody else that has had this error worked around it with the "nopat" kernel param; I tried that and it didn't help ( https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/1004546 )

I also messed with ServerLayout in xorg.conf a bit, wondering if 9600 horizontal pixels was too much:

Section "ServerLayout"
        Identifier     "aticonfig Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
        Screen         "amdcccle-Screen[1]-1" 1920 0
        Screen         "amdcccle-Screen[1]-2" 3840 0
        Screen         "amdcccle-Screen[1]-3" 5760 0
        # my failure occurs with either of these lines:
        Screen         "amdcccle-Screen[1]-4" 5760 1200
        # Screen         "amdcccle-Screen[1]-4" 7680 0

Update: 3840 Limit?

When I use the Ubuntu Displays configurator instead of AMD's thing, it seems to tell me that there's a hard limit of 3840x3840 for the entire virtual desktop:

requested position/size for CRTC 149 is outside the allowed limit: position=(3840,3840), size=(1920, 1200), maximum=(3840,3840)

Googling around, I see others encountering the same error with a variety of maximum limits - how is this number derived? How might I increase it?

As a workaround for now I can rearrange the screens on this dialog to fit inside the 3840x3840 square, but that doesn't reflect the physical layout of my displays.

I don't have enough rep yet on this stack exchange site to embed an image, but here's the dialog with the 3840 limit: http://i.stack.imgur.com/CKAld.png

  • To me, 5 displays connected to one card seems a bit too much. Maybe try to connect those monitors using low resolution first. Does it work that way?
    – Misery
    Sep 26, 2012 at 6:25
  • It works under Windows, and is a selling point of this card! (They call it "Eyefinity") I don't actually have five displays; I have two - one fairly standard 1920x1200, and one ridiculous 3840x2400 monster that acts as if it were four displays, using four single-link DVI cables. (IBM T221). I'm unable to test with lower resolutions because the display won't take them.
    – jrr
    Sep 26, 2012 at 15:05

1 Answer 1


I contacted AMD support, and I'm happy to report the "Not enough video memory to allocate primary surface (frame buffer)" issue is fixed as of Catalyst 12.11.

  • If that’s true, then it reappeared later. I have 15.201 and am facing exactly this issue.
    – MPi
    May 17, 2016 at 11:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.