I am running Ubuntu 12.04 LTS and I've been following whoopsie with the top program and noticed something strange.

In the afternoon the daemon process was only using up to 2% of CPU power.

But during the evening this slowly increased to sometimes taking up to 40% of CPU power.

I am running a 10 year old machine, but even VLC which is normally running OK was having problems running smoothly due to this increase in usage.

Since i am running an old machine, should I just switch whoopsie off (as descrribed in What is the 'whoopsie' process and how can I remove it?) or is there a way to let whoopsie behave less CPU hungry?

  • Well, I just notice this bug filed: Huge CPU loading by whoopsie & NetworkManager tandem. You might be able to confirm that new report. – valse-triste Sep 26 '12 at 0:08
  • @Ed Yes, I see the tandem combination with NetworkManager as well, also I believe deja-dup-monito to be involved. One thing which strikes me with this bug #1056393: when i also run the torrent program transmission, i can strongly see the mentioned tandem increasing cpu load. I guess transmission (during download) involves the NetworkManager and somehow triggers the bug. I will have a look to see if i can add my experience to the bug report. – Gertjan Sep 29 '12 at 9:07

I've got an idea as to how you could fix your problem: as a temporary measure you could cap the CPU usage of 'whoopsie' by using a program called CPU Limit.

You can download it below:

Install via the software center

This should ensure at least while watching movies that your film remains lag-free and once you've capped it, it shouldn't bother you until you next shutdown.I've found a well explained tutorial here if you need more information on how to install it and use it.

However as this isn't a permanent cap you'd need to get your Ubuntu to run it at startup each time if you want it to be capped on a more permanent basis. I'm not an expert on what commands you'd need to run but I think it should be possible to get it to run and limit the process at startup (see this post if you don't know how to set apps/processes to run at startup).

I'd suggest you try out CPU Limit and then if you're satisfied as to how well it copes with your problem and would like it to run at start-up you can use the instructions posted here by hhlp and by adding the following line:

cpulimit -e whoopsie -l 3 &

To the /etc/rc.local file it will run properly on every startup with Whoopsie capped at 3% cpu usage.

Ideally if it's a bug as commented it might be solved sometime soon, but until then this is the way I'd go about to stop the problem being an issue.

  • I've tried out your idea of using cpulimit. It works fine on processes I own, but it does not seem to work on processes owned by root (like whoopsie is). – Gertjan Sep 29 '12 at 8:31
  • you need to run the command with sudo in front, that will make sure you have the root privileges, it'll ask for your password and then do it normally – Oyibo Sep 29 '12 at 9:28
  • I've posted a useful link if you're not familiar with it HERE. It should work properly that way, but don't hesitate to post a new comment if the problem persists, if it works I'll edit this into the answer. – Oyibo Sep 29 '12 at 9:31
  • 2
    Thank you for your helpful comments. I appreciate them. My error in understanding was to add the cpulimit at startup (of the user login). Here I cannot use sudo (well unless I visudo cpulimit, which I do not like doing). Maybe I should add the cpulimit to some boot script. – Gertjan Sep 29 '12 at 15:38
  • 1
    yes, adding cpulimit -e whoopsie -l 3 & to /etc/rc.local (before the exit statement) resolves my problem. – Gertjan Oct 2 '12 at 9:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.