I am running ubuntu 12.04server, and trying to get pulseaudio working. I followed the instructions at How do I run PulseAudio in a headless server installation?

At the moment, pacmd list-cards is reporting 0 cards, aplay will only playing sound when I run it as sudo, and running alsamixer as sudo also works, but running it as my user produces "cannot open mixer: No such file or directory"

As far as I can tell, this means the the kernel module for my sound card is in fact loaded. I have already tried adding my user to the "audio" group, but this does not help. The permissions on the devices in /dev/snd are all

crw-rw---T 1 root audio 116

I noticed on an ubuntu 12.04 desktop, that the file permissions are slightly different. On the desktop, they are crw-rw---T+ 1 root audio 116

My questions are

1) How do I get aplay to work without running it as sudo on the server

2) Is there anything special I need to do to make pulseaudio work at this point.

  • Can you run alsamixer as non-root? It looks like a permission issue. – Takkat Sep 25 '12 at 20:02

To get aplay to work, check the permissions on the device nodes in /dev/snd/.

As for PA, it should then work just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.