0

Thanks in advance for any help. Ubuntu 12.04

Up until recently my mother has been using the Guest Session when she logs on; now, the Guest Session will not login. When I try to login to it, it bounces me back to the login screen.

I then tried to login on a Standard account (Alberta) which I made prior to not being able to login to Guest, and it turns out I cannot login - it gives the "Invalid Password" error.

So then I tried to change her password from my own account (Rory) which is the master account. Under the Login Options where the Password option is, it says "Account disabled" and it will not let me change this; I try to apply a password, get no error, but it just still says "Account disabled".

Then I tried to delete the Alberta account altogether, but got this error:enter image description here

  • Does it help to reboot the system? That should both clear any locks and should restart the dbus service that runs the /usr/sbin/userdel program. – John S Gruber Sep 26 '12 at 0:31
  • 1
    Possible duplicate of Ubuntu gets stuck in a login loop – karel Dec 22 '18 at 17:14
0

I have seen a similar issue in the past where a shadow lock file was left due to an application crash maybe related the original reason why the account wouldn't work.

Look for /etc/group.lock, /etc/passwd.lock and /etc/shadow.lock files and remove them.

*Note: Make sure to close all running applications and only remove the .lock files *

  • I deleted /etc/group.lock and /etc/shadow.lock, it said /etc/passwd.lock could not be located. Even with /etc/group.lock and /etc/shadow.lock removed, I still could not log in to the other accounts. – Rory Sep 25 '12 at 21:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.