A couple of days ago I bought an Acer Aspire V3-571G laptop without a system installed on it. The only thing that was there was Linux Linpus. I created a bootable CD with Ubuntu 12.04 64-bit - I read that my processor was 64 bit and that it might be a good configuration for my gear (I'm not especially fluent with all the computer stuff, still trying to learn) and replaced Linpus with Ubuntu.

Everything seemed to work fine, but there're few exceptions to that which came pass my way.

  1. My bluetooth doesn't work. It seems to be switched on, but when I check my system settings the button is actually off, and I can't drag it 'perminently' to the 'on' position. Tried a couple of commands I found on the net, none of them helped and there was no word whatsoever in my BIOS settings about enabling bluetooth.

  2. My card reader has some serious problems with copying more than one file at a time. I tried to put some music on my phone through a MicroSD card adapter (because my bluetooth doesn't work) and it got stuck every single time I copied an album on it.

  3. I'm not sure if all my drivers were properly installed, so I checked in the terminal if it could tell me sth about my graphics.

    typed: sudo lshw -c display and what i got was:

    *-display UNCLAIMED     
         description: VGA compatible controller
         product: NVIDIA Corporation
         vendor: NVIDIA Corporation
         physical id: 0
         bus info: pci@0000:01:00.0
         version: a1
         width: 64 bits
         clock: 33MHz
         capabilities: pm msi pciexpress vga_controller cap_list
         configuration: latency=0
         resources: memory:b2000000-b2ffffff memory:a0000000-afffffff memory:b0000000-b1ffffff ioport:2000(size=128)
         description: VGA compatible controller
         product: Ivy Bridge Graphics Controller
         vendor: Intel Corporation
         physical id: 2
         bus info: pci@0000:00:02.0
         version: 09
         width: 64 bits
         clock: 33MHz
         capabilities: msi pm vga_controller bus_master cap_list rom
         configuration: driver=i915 latency=0
         resources: irq:44 memory:b3000000-b33fffff memory:c0000000-cfffffff ioport:3000(size=64)

As I said I'm no expert and not english-speaking generally, but it doesn't seem to be right. I've got a NVIDIA GeForce GT 640M.

  • Did you look on the proprietary driver for the bluetooth driver? – lambda23 Oct 11 '12 at 2:12

Try this to correct the brightness adjustment problem:

  1. Open a terminal (Ctrl + Alt + T).
  2. Then type sudo nano /etc/default/grub. It will ask for your password. Type it in.
  3. Around the 11th line, there will be something like: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash". Change it to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
  4. Save the file by Ctrl+O followed by Ctrl+X. Then run sudo update-grub in the terminal.
  5. Reboot and see if backlight adjustment works. If not, undo the changes you did above, by invoking the text editor as in steps 1 and 2.

Hope it helps.

Works for Acer Aspire v3-571,Acer Aspire v3 571g,Hewlett Packard Bell EasyNote TS,Acer Aspire 4755G,Acer Aspire 5750-6866


I also got the same laptop a while ago - unfortunately there are quite a few problems with the hardware under linux (for me - maybe you'll have better luck)

so here is what I can help with

  1. For the Bluetooth, i think the problem is that you have it Hard blocked on your machine. Hitting Fn + F3 should toggle between all the variation of WiFi on/off, BT on/off. use the command rfkill list to see current state (you may need to wait a few seconds for the change) But for me this doesn't fix BT performance - it fails to list the available devices. I tried with a BT mouse and a phone ... there are some guides you can find on the net for this - none worked reliably for me.

  2. haven't used this, so dunno

  3. The issue is that the 640M uses the NVidia Optimus technology ( http://en.wikipedia.org/wiki/Nvidia_Optimus ) which isn't officially supported on linux, but this howto shows how you can get it working: https://wiki.ubuntu.com/Bumblebee

Other issues i have include not being able to control the screen brightness (Fn + Left/Right arrow key) or even from the display settings.

And for the WiFi it seems i managed to have it work reliably by having BT hard blocked and creating the file /etc/modprobe.d/ath9k.conf with contents options ath9k nohwcrypt=1 But this means no BT mouse.

Good luck


I'm using 12.10 not 12.04 on a Aspire V3-571G and there is a package you can install and some commands to fix your bluetooth.

See: Bug #1024884: Bluetooth with AR9462 WLAN/BT-Combo don't work

Download ar9462-dkms_1.4-3.5_all.deb and linux-firmware_1.100_all.deb

Instructions would be:

sudo apt-get install g++ dkms linux-headers-`uname -r`
sudo dpkg -i Downloads/linux-firmware_1.100_all.deb
sudo dpkg -i Downloads/ar9462-dkms_1.4-3.5_all.deb
sudo dkms install ar9462/1.4-3.5
dkms status

You should see:
ar9462, 1.4-3.5, 3.5.0-21-generic, x86_64: installed

Reboot and enjoy.

I'm using a bluetooth mouse now, but before the "hcitool scan" would return nothing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.