I'm maintaining a 10.04 server that is still booting off of the 2.6.32-28 kernel even though a bunch of later kernels are available. My best guess is that the immediately following version was purged from dpkg.

When I run:

dpkg --list 'linux-image*'

I get:

un  linux-image                               <none>                                    (no description available)
un  linux-image-2.6                           <none>                                    (no description available)
un  linux-image-2.6.24-23-server              <none>                                    (no description available)
ii  linux-image-2.6.32-28-server              2.6.32-28.55                              Linux kernel image for version 2.6.32 on x86_64
un  linux-image-2.6.32-31-server              <none>                                    (no description available)
un  linux-image-2.6.32-33-server              <none>                                    (no description available)
un  linux-image-2.6.32-34-server              <none>                                    (no description available)
ii  linux-image-2.6.32-37-server              2.6.32-37.81                              Linux kernel image for version 2.6.32 on x86_64
ii  linux-image-2.6.32-38-server              2.6.32-38.83                              Linux kernel image for version 2.6.32 on x86_64
ii  linux-image-2.6.32-41-server              2.6.32-41.94                              Linux kernel image for version 2.6.32 on x86_64
ii  linux-image-2.6.32-42-server              2.6.32-42.95                              Linux kernel image for version 2.6.32 on x86_64
in  linux-image-2.6.32-43-server              <none>                                    (no description available)
iU  linux-image-server                                            Linux kernel image on Server Equipment.


uname -r

Prints: "2.6.32-28-server"

I don't know how it got like this, but I think it might be from a script that last server admin had run to automatically delete old kernels.

Anyways, if I reinstall *-image-2.6.32-31, should it automatically run off of it after a reboot? Or is there another/simpler way to get to the latest version without reinstalling the purged kernels? This is a live server, and I'd don't want to go guessing and checking on this one.

FYI, this whole problem stems from the fact that the hosting company of this server set up to boot partition to only be 80M and it's currently maxed out.

  • You might just need to run sudo update-grub – charlesbridge Sep 24 '12 at 18:30
  • Thanks for the comment. I ran that and rebooted, but I'm still on *2.6.32-28. Also, I think that update-grub is run automatically by apt-get when removing (and I think upgrading, too) kernels. – user1034772 Sep 24 '12 at 18:48
  • It should, but I've had it either not run or fail and ended up using older kernels without realizing it. – charlesbridge Sep 24 '12 at 20:29

I think your problem is that your /boot mountpoint is not the one that GRUB points to. Try to mount /boot partition to some temporary mountpoint such as /media/boot and see if it has the same files as /boot.

if it's true, one thing you can do is to mount boot partition to /boot (put it in /etc/fstab) but stay careful because any mistake can cause your computer be unbootable.

Another option is to run grub-install so GRUB code in MBR (Stage 1) will point to your current /boot ("/" mountpoint).

Another thing you mentioned, you might have problem with 80MB partition. you have to make sure you have kind of maximum of 2 kernel versions.

Read about those things before.

  • Thanks idgar, I'll read up on your suggestions and post back. – user1034772 Sep 24 '12 at 20:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.