4

I'm trying to remove LXDE from my 12.04 system.
I've tried running the following commands (as root from a terminal):

apt-get remove lxde
apt-get purge lxde
apt-get autoremove

I've also tried a rather lengthy command that was linked to from another question.

However, when I log in, LXDE is still presented as an environment choice, and it still functions perfectly well, as if I've done nothing.

I ran the above commands again, but got the following message:

package . . . is not installed, so not removed.

So, where do I go from here, short of re-installing Ubuntu and all my programs?

3
  • LXDE is a metapackage and you need to know the name of packages installed during first installation to remove them. take a look to this similar question
    – Anwar
    Commented Sep 24, 2012 at 17:23
  • Can you post the output of the "lengthy command", perhaps something didn't work there. Have you installed lxde or lubuntu-desktop? Commented Sep 24, 2012 at 17:50
  • @Anwar I removed lxde-core and tried removing all the dependencies given by the original install (used apt-get install -s lxde to get list). still though, when I log in, LXDE still shows up (AND FUNCTIONS) as an environment choice in the menu. Commented Sep 26, 2012 at 17:33

3 Answers 3

3

I don't know if you got this solved by now or not, but I think your problem is lxde-core is itself a meta package. To reverse

apt-get install lxde

you need to

apt-get remove lxde gpicview leafpad lxappearance lxde-core lxde-common lxinput lxmusic lxpanel lxsession lxsession-edit lxshortcut lxterminal openbox-themes openbox pcmanfm xarchiver xscreensaver
apt-get autoremove
2

What you can do is, to first, check the dependency of the lxde.
You can do this using the apt-cache command.

sudo apt-cache show lxde

This enables you to remove dependency packages.
So far, this has worked for me!

0
sudo apt autoremove --purge lxde*

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .