Possible Duplicates:
Unable to install Skype on 64bit Ubuntu
Fixing Broken Packages

Hi there I am trying to install Skype through apt-get but I am having some trouble. The Skype package depends on skype-bin which is not found in my list of packages.

So when trying to install Skype I get the following error.

$ sudo apt-get install skype
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 skype : Depends: skype-bin but it is not installable
E: Unable to correct problems, you have held broken packages.

Does anyone know why this might happen? Am I missing a repository?

I get similar results when downloading the .deb from their site. But it complains about ai32-libs not being installable. This is because it depends on another package that does not exist in my list.

Please bear in mind that this is a custom install from the company I work for. They have secured it and I think they have updated it over time and skipped versions, possibly breaking things.

marked as duplicate by Tom Brossman, Mitch, Takkat, RobotHumans, hexafraction Sep 24 '12 at 19:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • The fix packages command (sudo apt-get install -f) does nothing. So does auto remove. So does update. Nothing seems to change anything. It's as if skype-bin and a few other packages that should exist can not be found. – Wolfy87 Sep 24 '12 at 13:06
  • Maybe try one of the answers here then? If not, you may need to speak to someone doing IT support at your company and see what they did. This might be too localized to your machine. Good luck and hope you get it sorted. – Tom Brossman Sep 24 '12 at 13:10
  • I have tried a few from there and synaptic. Everything is the same. I think this is the main problem, or one of them anyway: ia32-libs : Depends: ia32-libs-multiarch but it is not installable. – Wolfy87 Sep 24 '12 at 13:17
  • This was closed because it is a broken packages issue? Oh... but it isn't, it's nothing to do with broken packages. I can install packages, just not specific ones such as Skype or Wine. And it is something to do with the 32 bit wrappers for as 64 bit machine are missing. This should not be closed. – Wolfy87 Sep 26 '12 at 15:36
  • The error message copied into your question says 'you have held broken packages', which has everything to do with broken packages. Have you tried the answers at the possible duplicate? If they don't help it may be down to your custom install which you admit may have broken things. If that's the root cause then the question still gets closed, but as 'too localized' instead. If your issue clearly lies within the FAQ I'm happy to help but not all questions here are eligible for answers, sorry. Try Canonical's 'Ubuntu Advantage' paid support since this is a work machine. – Tom Brossman Sep 26 '12 at 19:43

Install Synaptic if you haven't yet then in Synaptic choose to show broken packages then mark them and remove then reinstall or also you can update/upgrade your packages to met the dependencies...anyway I advice you Synaptic will solve your problem.

To install skype in correct way:

sudo apt-add-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"

sudo apt-get update

sudo apt-get install skype

It seems that installing from Ubuntu repositories install a 2.2 version of Skype.

#> skype --version
Copyright (c) 2004-2011, Skype Limited

Conversely, the official Skype website offers a 4.0 version of Skype for Ubuntu 32/64bit. To install it, download the .deb package from the website(32bit or 64bit), then run:

aptitude install lib32stdc++6 libstdc++6 lib32asound2 ia32-libs libc6-i386 lib32gcc1

and then

dpkg -i skype-ubuntu_4.0.0.8-1_amd64.deb (or its 32bit counterpart)

At the end you will have a 4.0 version of Skype installed.

#> skype --version
Copyright (c) 2004-2012, Skype
  • The version in the repos right now is skype, and it's simplest to use that way of installing it. – Tom Brossman Sep 24 '12 at 12:56
  • As @TomBrossman says, the repository version is up to date. The problem is not with the Skype installation but with it's dependencies. It is looking for skype-bin which does not even exist to my install. It seems to be something to do with what repositories my Ubuntu is looking at, but I am not sure. – Wolfy87 Sep 24 '12 at 13:04
  • Have you tried an aptitude update first? That's the most common cause of incoherence between packets. – Avio Sep 24 '12 at 13:07
  • If by that you mean sudo apt-get update, then yes. Multiple times. It seems to stem from the same problem that causes wine to be uninstallable. Because I also can not install wine. – Wolfy87 Sep 24 '12 at 13:11
  • Even if it's a little bit drastic, you could give a try to the solution proposed in comment #3 of this thread – Avio Sep 24 '12 at 13:23


Ubuntu fix broken package (best solution)

After trying

sudo dpkg --configure -a


sudo apt-get install -f

the problem of a broken package still exist the solution is to edit the dpkg status file manually.

$ sudo gedit /var/lib/dpkg/status (you can use vi or nano instead of gedit) Locate the corrupt package, and remove the whole block of information about it and save the file.

----------------- skype ---------------


Skype 4.0 ppa:upubuntu-com/chat

sudo add-apt-repository ppa:upubuntu-com/chat

sudo apt-get update

sudo apt-get install skype

Skype wrapper for Ubuntu ppa:skype-wrapper/ppa

sudo add-apt-repository ppa:skype-wrapper/ppa

sudo apt-get update

sudo apt-get install skype-wrapper

Not the answer you're looking for? Browse other questions tagged or ask your own question.