2

I wish I could be more specific. I installed the upgrade from the update manager and after the computer rebooted, I found I could not run a lot of programs. I tried running them from the command line to see what errors I would get:

update-manager:

Traceback (most recent call last):
  File "/usr/bin/update-manager", line 32, in 
    from UpdateManager.UpdateManager import UpdateManager
  File "/usr/lib/python2.6/dist-packages/UpdateManager/UpdateManager.py", line 36, in 
    import apt
ImportError: No module named apt

so I need to install python-apt, right?:

Reading package lists...
Building dependency tree...
Reading state information...
python-apt is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  amarok: Depends: phonon-backend-xine but it is not installable or
                   phonon-backend
          Depends: libmtp8 (>= 0.3.1) but it is not installable
          Recommends: kdemultimedia-kio-plugins (>= 4:4.2.0) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
[300+ lines omitted]

It looks like I was half way through the upgrade when something broke. apt-get -f install gives the same errors as above. I have tried a few commands from the forums all with no luck so far:

apt-get install -o APT::Immediate-Configure=false -f apt python-minimal
  ran into the same dependencies problem
removing 3rd party sources from /etc/apt/sources.list
  these were already commented out 

I can run synaptic, but it tells me I have 181 broken packages. Is there any hope of restoring this system? I would rather not reinstall from CD, but it looks like I may have to.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.