I'm totally lost.

I've just built a new system and installed Ubuntu 12.04. It's my first time with Linux and getting into the terminal / command line for the first time since IBMDOS 5 and Windows 3.1 has been a steep learning curve.

However, the interface works beautifully apart from it doesn't recognize my Hanvon Artmaster AM1209.

I have sent diagnostics to Digimend and Favux was kind enough to advise that the tablet should be using the Wacom X driver as the Hanvon is actually a Hanwang and these should be supported.

lsusb reports: ID 0b57:8501 Beijing HanwangTechnology Co., Ltd  
xinput list reports:  
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ PS/2+USB Mouse                            id=8    [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Eee PC WMI hotkeys                        id=9    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=10   [slave  keyboard (3)]

Favux suggested inspecting /var/log/Xorg.0.log for the tablet but I cannot see any mention of it, and that is as far as I have got.

I've tried researching the problem but I am struggling with all the new terminology and the fact that I want the PC to be a means to an end and not the end in itself where I spend the rest of my days tweaking and testing rather than just using it.

Hope there is some help out there.


This was also open on launchpad.
Many, many thanks to CLAW for his time and patience. The driver on English version of the page linked by actionparsnip:
Hanvon Art Master Driver for Linux
was a different version to the ones I'd tried before. Initially it gave button only input on the stylus, but a clean installation of Ubuntu appears to have done the trick and I have a functioning tablet. I think my blundering about with trying to solve this problem must have destabilized ubuntu. Thanks again to ACTIONPARSNIP & CLAW

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.