Because zeitgeist continuously access the hard disk, I removed zeitgeist package completely. After that, when trying to log into Ubuntu, there is no more unity option, only Genome, Genome (no effects), etc. And even Genome doesn't work normal. Say pressing tab doesn't switch window, cannot open folder in the explorer.

I tried to reinstall zeitgeist. The problem remains. When I run unity --reset in Genome session, the sidebar appears, the unity seems back. But if I close the command window that runs "unity --reset", the unity disappears. And I still don't have the option to log into unity next boot.

Can any one help me to restore unity?



Use this to Remove/Uninstall Compiz Unity:

sudo apt-get remove compizconfig-settings-manager

sudo apt-get remove compiz-fusion-plugins-extra

sudo apt-get remove compiz-plugins-extra

sudo apt-get purge compiz*

Then to Re-install Compiz Unity use:

sudo apt-get install unity-2d

sudo apt-get install ubuntu-desktop

sudo apt-get install ubuntu-desktop-2d

sudo apt-get install compizconfig-settings-manager

sudo apt-get install xserver-xgl

sudo apt-get install emerald

sudo apt-get install compiz-fusion-plugins-extra

sudo apt-get install git compiz-plugins-extra

sudo apt-get install compiz-plugins-extra

sudo apt-get install unity

  • Thank you very much! Now Unity is back finally! Just another question, the thunderbird seems has "lost" its memory of my email accounts. Can I recover it, so that I don't have to set up several email accounts again? – Fashandge Sep 22 '12 at 23:37
  • There is a link nazly.net/… that explains how to delete the profile while keeping the old settings and then creating a new profile importing the old settings. – daslinkard Sep 23 '12 at 0:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.