64

A lot of applications like Firefox, Chrome etc, get closed when I accidentally press Ctrl+Q instead of Ctrl+W because of the proximity of the Q and W keys on the keyboard. Is there a way this shortcut can be removed or reset on a system wide basis?

10 Answers 10

91

The best way is to disable the keyboard setting in your specific application. For Firefox there is an extension keyconfig. This allows you to change keyboard settings.

If you want to disable Ctrl+Q for your whole system, I would suggest to make a new setting:

  1. Go to System -> Preferences -> Keyboard settings
  2. Click Add
  3. Give it a name like fake setting and enter /bin/false as command. Apply your changes.
  4. Click on 'Disabled' and press Ctrl+Q.

Now you should have a new entry with your applied name and your keyboard setting. Every time you press Ctrl+Q your system will run the command /bin/false which basically does nothing. So this is a workaround to disable the setting.

13
  • 2
    Awesome answer, and how did you do the styled button shortcuts! :)
    – jathanism
    Aug 11 '10 at 13:37
  • 3
    @jathanism: Use the kbd html tag. Aug 11 '10 at 15:33
  • 4
    When you want to press Ctrl-Q the window will close. You can never assign this key using this method
    – Anwar
    Oct 15 '12 at 6:23
  • 3
    @AnwarShah -- I just tried this solution and it worked for me.
    – Sam King
    Apr 20 '14 at 5:22
  • 1
    keyconfig no longer works in Firefox 57. Sep 26 '17 at 15:12
6

Probably inserting the shortcut under System -> Preferences -> Keyboard Shortcuts and "disabling" it should do the trick.

4
  • 7
    Instead of just typing away do a bit of research if your not 100% certain. It would have costed you 2 secs to find that it is not there. Aug 11 '10 at 7:33
  • 1
    Well, it is if you add it, isn't it? Maybe I didn't express myself correctly. But apparently, there is an easy fix since it's worked for me.
    – mariachris
    Aug 11 '10 at 9:04
  • Maybe not, it is still not a very nice way to do it... This way you will never be able to use Ctrl+W for any thing! For instance in bash Ctrl+W means delete word backwards. Aug 11 '10 at 11:13
  • It does work and it is exactly what has been asked for. @LassePoulsen why should CTRL+W be affected from this?
    – Murmel
    Dec 1 '16 at 15:54
5

You can go to System → PreferencesKeyboard Shortcuts and assign this combo to an unused action. For example I assigned Ctrl+Q to switch to workspace 12 (no, I don't have 12 workspaces).

As a result this system wide setting overrides application one and Ctrl+Q no longer closes Firefox (likely the combo never reaches Firefox). It just does nothing.

3
  • Kind of a nice and easy fix, but I rather recommend to use a browser's extension. Using system preferences to override Ctrl+Q system-wide would result in some applications being unable to use that shortcut - e.g. you won't be able to use Ctrl+Q in IntelliJ IDEA to show documentation pop-up.
    – falconepl
    Jun 27 '15 at 14:48
  • 2
    Well, the question is about disabling this combo system-wide not app per app ;). Jun 29 '15 at 6:30
  • And that's why you've got +1 from me... ;)
    – falconepl
    Jun 29 '15 at 13:57
3

For newer Firefox versions, you can disable it as follows:

  1. Go to about:config.
  2. Set browser.quitShortcut.disabled to true.
  3. Restart the browser.

For other applications, the steps will differ. Chrome no longer closes on Ctrl+Q, so there is no need to change anything there. Note that in many other applications, Ctrl+Q is a useful shortcut, so disabling it system wide would break that functionality.

3

If Ctrl + Q closes the keyboard settings window, like it did for me, youi can do the following:

  1. Set the shortcut to another value.
  2. Close the window and wait until the updated shortcut appears somewhere in ~/.gconf/desktop/gnome/keybindings/*.
  3. Open that file and edit the stringvalue of that command to read <Primary>q.
  4. Reboot the PC.

This worked for me as opposed to the accepted answer.

2
  • Even that did not work for me. I tried the below: <?xml version="1.0"?> <gconf> <entry name="action" mtime="1369776357" type="string"> <stringvalue>/bin/false </stringvalue> </entry> <entry name="name" mtime="1369776357" type="string"> <stringvalue>dummy2</stringvalue> </entry> <entry name="binding" mtime="1369776299" type="string"> <stringvalue>&lt;Primary&gt;q</stringvalue> </entry> </gconf> May 28 '13 at 21:26
  • 1
    I had to restart gnome session, but this worked, thanks! Jun 25 '14 at 18:15
2

Here is a command-line version of the already-supplied GUI version. On some systems Ctrl+Q will close the accelerator input window without setting the shortcut, so this can be needed:

gconftool-2 --type string --set /desktop/gnome/keybindings/inhibit_ctrl_Q/name "Inhibit Ctrl+Q"
gconftool-2 --type string --set /desktop/gnome/keybindings/inhibit_ctrl_Q/action /bin/false
gconftool-2 --type string --set /desktop/gnome/keybindings/inhibit_ctrl_Q/binding "<Primary>q"

Note that this solution is for GNOME 2/Unity. A similar solution should be possible with gsettings for GNOME 3.

1
  • It seems that these settings although preserved after restart does not provide expected behavior (Ubuntu 14.04). Also, after being applied, using Ctrl+Q shortcut with focused Nautilus window makes it hang/unresponsive.
    – falconepl
    Jun 27 '15 at 14:21
2

My current workaround is to create a new shortcut in System Settings → KeyboardShortcuts. If the shortcut is accidentally pressed, we receive an informative message.

  • Title: Quit Prevention
  • Command: notify-send 'Dear idiot' "Don't press ctrl-Q"
  • Shortcut: Ctrl+Q

This disables the command system-wide, however, which might be an acceptable tradeoff depending on your use case.

The above is Tested in Ubuntu 16.04.

0
1

On Linux with Firefox Quantum, there is currently a bug that prevents extensions and explicit configuration from changing a built-in shortcut such as Ctrl+Q.

A workaround is to block it at the system level by e.g. installing the script from https://github.com/sasawat/firefox-ctrl-q-workaround and assigning it as the action of Ctrl+Q as a global shortcut.

1
  • As of mid-2018, this must be the correct answer.
    – bytebuster
    Aug 24 '18 at 22:58
0

For me, disabling the Ctrl+Q shortcut system-wide is not the perfect solution, because it prevents applications other than Firefox, Chrome etc., to be notified when you use that shortcut. For example, IntelliJ IDEA uses Ctrl+Q as a default binding to show quick documentation pop-up.

If you are looking for a Firefox-only solution, I highly recommend Disable Ctrl-Q Shortcut plugin. In my opinion it's a better option than keyconfig mentioned by @qbi because its source is available on GitHub, while keyconfig is available only as a binary.

-1

My way is going to System → PreferencesKeyboard Shortcuts (yeah I know it's not there). Here you add one more shortcut with the Name "Do nothing", with a random Command with the Shortcut Ctrl+Q. Then the deadly combo should not bother you anymore anywhere.

screenshot

1
  • This is not an appropriate solution because the command "a" will run every time Ctrl+Q is pressed. And it will override shortcuts of other applications too.
    – preIdiot
    May 30 at 2:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.