4

I have installed Ubuntu 12.04.1 on my new Lenovo IdeaPad Y580 M772DGE. Unfortunately the right mouse button of the touchpad is not working correctly. Every mouse button click is interpreted as a left mouse button click. I tried to uninstall and reinstall the synaptics (xserver-xorg-input-synaptics) drivers, but the problem is still present.

What else can I do? Any other suggestions? Is it possible to emulate a right mouse click event with a keyboard key?

  • For anyone looking at this question it is definitely worth checking out this answer to a related (duplicate?) question: askubuntu.com/a/1029458/800252. It solved the problem for me (even though it seems counterintuitive since I do have a physical right mouse button. Still selecting the area emulation in Gnome Tweaks makes the physical mouse button work. – Kvothe Jun 12 '18 at 14:24
4

I think I can give you the answer

Open a terminal, then type:

echo "options psmouse proto=exps" | sudo tee /etc/modprobe.d/psmouse.conf

Enter your password when prompted and then press Enter.

Now, while your right mouse click should be working after a reboot, you can try doing it without a reboot, but it might crash your desktop. It didn't for me, so here it is, type in the same terminal as root:

sudo modprobe -r psmouse; sudo modprobe psmouse

hope that helps!

edit: ok, so now that the right button works, the touchpad section of the mouse settings disappeared, and so did my custom settings and the multitouch capability, which resulted in a slow mouse pointer and no ability to scroll. I think I'll write a bug report on this one.

edit2: I searched through the web, and apparently, there is some obscure way to fix this problem, but it relies on ressources and patches that aren't available so easily anymore. I fixed this problem for me by upgrading to quantal quetzal, which includes adequate (albeit not great) support for multitouch clickpads by default

| improve this answer | |
  • thank you for your answer! I guess it would be the best to wait these few days until the final quantal quetzal release is available and hoping that ubuntu 12.10 will support the mousepad of my lenovo y580 by default. Thank you very much! – sockeqwe Oct 3 '12 at 13:44
0

Find and open the file: /usr/share/X11/xorg.conf.d/50-synaptics.conf

Find the paragraph :

# This option enables the bottom right corner to be a right button on clickpads
# and the right and middle top areas to be right / middle buttons on clickpads
# with a top button area.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Default clickpad buttons"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
        Option "SecondarySoftButtonAreas" "58% 0 0 15% 42% 58% 0 15%"

Add 2 line before Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"

Option "ClickPad"         "true"
Option "EmulateMidButtonTime" "0"
| improve this answer | |
0

The top answer by @elpollodiablo did not work for me on Ubuntu 18.1 on a Dell Inspiron 15 5000 series. As for the second answer, I do not have a file /usr/share/X11/xorg.conf.d/50-synaptics.conf to edit.

Instead I found this link instructing me to install Gnome Tweaks -> Keyboard -> Touchpad -> Mouse Click Emulation. http://ubuntuhandbook.org/index.php/2018/07/touchpad-right-click-not-working-in-ubuntu-18-04/

That worked.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.