I know this might seem like a repeat question, but I've literally looked over 100 threads on how to get SC2 to work on ubuntu 12.04 through wine and none have worked.

I downloaded wine new today, and inserted my purchased SC2 disk.

When I try to open the installer (installer.exe) with wine, an error appear saying:

"No installer data could be found. If this problem persists, please contact Blizzard Technical Support."

I searched for solutions to mediate this issue and was directed to the following source: http://ubuntuforums.org/showthread.php?t=1435314 .

I followed directions through until I got to


I tried various combinations of (ls installer.exe, ls'/home/rothic/Desktop/Installer.exe, etc.)

All come back with "no such file or directory".

Im not sure what to do, the next step would be to replace the "starcraft_installer" with the starcraft installer file, which Im not sure how to do (very new to linux).

I tried WINEPREFIX=~/.wine_starcraft/ wine starcraft_installer

and it says "wine: cannot find L"C:\windows\system32\starcraft_installer.exe"

despite it being on the desktop as advised.

Any suggestions on where to go from here?

  • 'ls' is only a program to lost files matching a name. It does not do anything except give you info.
    – nanofarad
    Sep 22, 2012 at 19:08
  • Still, If I skipped that step, I run into trouble. Hence me continuing with my explanation. Why can't wine find L"C:\windows\system32\starcraft_installer.exe ? Sep 22, 2012 at 19:22
  • Nice question. I hope you'll find someone able to write a small tutorial. @ObsessiveFOSS, ls lists files (I know that "lost" is just a typo but it's better to be clear when explaining the basics). It's something like the dir command in Windows. But you're right, executed alone it can't in any way tamper your Starcraft II setup.
    – Avio
    Sep 28, 2012 at 6:41
  • Uh, BTW, the official WineHQ Starcraft II page is the best place to find this kind of solutions. It's rated gold by a bunch of people. At least now you know that this thing is doable.
    – Avio
    Sep 28, 2012 at 6:49

2 Answers 2


Well, you skipped the important part in those instructions: "navigate to where you put the starcraft installer, and..."

When you put in a CD, Ubuntu mounts it in a sub-directory of /media/, so first you need to navigate there:

cd /media

the last command will print a list of directories which correspond to your mounted devices. Identify which one correspond to you CD (cdrom would be my guess), then

cd cdrom 

then, if you see starcraft_installer.exe in the output, you can proceed with the instructions.

  • I changed directories and found the cdrom. When I run wine by doing rothic@Rothic:/media/SC2-L100-D1$ WINEPREFIX=~/.wine_starcraft/ wine Installer.exe An error arises as the following: No installer data could be found. If this problem persists, please contact blizzard... Its the same thing as just clicking the file and selecting wine as the program to run. Any thoughts on this? Sep 22, 2012 at 21:31

I'm using Ubuntu 12.10, but it's probably the same for 12.04

If you use PlayOnLinux, you can install the game easily:

  • Go to Battle.net, log in or create an acount.
  • Click "Add a game", use your product key that is included with your software, and chose to save the file when asked. DO NOT choose "run".
  • Open PlayOnLinux, choose install, click games, then scroll to Starcraft 2 and select it.
  • After the virtual drive is created, it will ask if you want to install from a disc or file. Choose file and browse to the file downloaded from Battle.net and click open.

If you haven't a had any luck, I hope this helps. If you've already gotten this to work, I hope it helps someone else.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .