154

I need to install more than 100 fonts, so I was wondering if there is an easy way to do this task?

I know you can opening every single one and pressing install font, but installing more then 100 fonts this way will be very time-consuming.

In my home directory i have only .fontconfig and I do not have .Font.

In /usr/share/fonts I cannot copy files because I don't have permission

Is there an easy and fast way to do this task?

225

Just create a .fonts folder in your home directory (if it doesn't exist) and unpack/copy them there.

It's also a good idea to manually rebuild the font cache, so you can immediately use the fonts everywhere:

fc-cache -f -v

For more details see also https://wiki.ubuntu.com/Fonts

  • In home directory i only have .fontconfig should i create .fonts in home directory and place fonts there ?? will libreoffice notify them ?? – Levan Sep 22 '12 at 16:19
  • 1
    Yes, just create a new directory. Make sure you name it exactly .fonts Directory names starting with a dot will not be visible by default, but you can navigate into this folder later by pressing Ctrl+L in the file manager. – artfwo Sep 22 '12 at 16:21
  • 7
    The default place for user-specific fonts now appears to be ~/.local/share/fonts. ~/.fonts should still work, though. – Thomas W. Nov 22 '16 at 14:13
  • Cool, it worked like a charm in Mint 19. thumbs up – Luis Milanese Dec 22 '18 at 16:44
46

Font Manager

Can manage multiple fonts easily with this application.

Can install mutiple fonts at a once.

enter image description here

To install new fonts click on "Manage Fonts" button as on the picture and click on "Install Fonts" in menu.

Can be installed with Software Center or with this command;

sudo apt-get install font-manager
  • I can recommend font-manager. It's very useful for managing your fonts and can do bulk install as well. – David Jun 9 '15 at 14:17
  • Font Manager seems to have become unstable on 16.04. On my system, it hangs while "Querying installed files...". – iGadget May 6 '16 at 12:16
  • I am using font-manager on Mint 18 (based on Ubuntu 16.04) and font-manager worked fine. – Lucio Mollinedo Jul 12 '17 at 18:11
19

Let's say your downloaded fonts are in fonts directory in your Downloads folder, Do these to install them

If you want the fonts to be usable by all users

Copy in /usr/share/fonts with command line

sudo cp -r ~/Downloads/fonts /usr/share/fonts/truetype/

Alternatively, Type this command in terminal to open graphical file manager if you prefer that way

sudo -i nautilus /usr/share/fonts/truetype

and copy the fonts from the downloaded directory to the newly opened folder in nautilus

If you don't bother for all users

In this case, the recommended way is to copy the fonts in ~/.local/share/fonts directory (It is not recommended to create .font directory directly under home anymore). When you put the fonts in that specified directory, Ubuntu will automatically start caching process. After 5-6 seconds, the fonts should appear in listing. Close any open application before you want to change the font for it.

Fixing the font files' permission bit

Font files should have the permission of 644 and the containing folder should have 755. So if you see don't see the fonts in listing, please check the permissions of those files and folders.

  • UNEXPECTED RESULT! Gimp crashes when scrolling to change font in the Text Tool (under Tool Options). – its_me Oct 27 '12 at 2:17
7

Open your synaptic package manager and choose fonts from left side category menu . it will list all the fonts and you can select as many as you want and all will install with one go .

while coming to the rights issue while copying to /usr/share/fonts location , you should be root .

I mean

sudo cp <your_file> /usr/share/fonts/ 

will do it .

hope that helps .

  • sadly fonts that are present in synaptic is not sufficient enough for Georgian and Russian languages ah copying with terminal files is like chines for me, I remember a long time ago some one told me a commend that opened fonts folder automatically and i could drag and drop files in to it is there a chance that you know that command ?? – Levan Sep 22 '12 at 16:22
  • Hi try the copy code i have given to you . – rɑːdʒɑ Sep 22 '12 at 16:23
2

I found the following answer, found above, very helpful:

Just create a .fonts folder in your home directory (if it doesn't exist) and unpack/copy them there. It's also a good idea to manually rebuild the font cache, so you can immediately use the fonts everywhere: fc-cache -f -v

In Ubuntu 16.0.4 the Font Viewer application is not working properly so this workaround is a must. I found it much easier to add fonts in bulk by dragging and dropping to the .fonts directory in home. For me, this directory already existed! In home, cntrl-l gives access to the home/user path in the title bar of the window, I added to it typing /.fonts and pressed enter, this gave me access to the .fonts folder. I then simply copied in the fonts I wanted by dragging and dropping from another window and then opened the Terminal. If your unfamiliar with Ubuntu to find the Terminal use the top most button in the bar at left "search your computer". When the window opens click on the applications button at the bottom of the window, it looks like an "A", you can then search your installed applications. Click on "Installed" in the window and scroll down until you see terminal. At the prompt type in the command and press enter. Wait patiently! You'll be good to go when it's completed. By the way, when the Terminal is open it appears in the bar at left and you can lock it there for future use by right clicking and choose an option from the context menu. Handy!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.