4

If I change the desktop background (wallpaper) via right-click on desktop => desktop settings => single image, and select another background image from the list, or add a photo of my own (via the "+" symbol), I can actually change the background image, but after logging out or restarting, the wallpaper is always reset to the original xubuntu 12.04 background.

So, basically, I can't find a way to permanently change the desktop background.

Any ideas?

1
  • Well, after some more research I have found out that this should actually a Xubuntu bug. My solution: I installed "Wallch". Works like a charm.
    – Frank
    Sep 22, 2012 at 13:55

2 Answers 2

2

Because of the way Xfce is built, if you change settings and do not save session, the changes are not saved. It is not automatic. Menu -> Log out -> save session must be checked.

0

I also encountered this problem but in Ubuntu 14.04.3: right-click on desktop>change desktop settings>add own image using + and "span" it across my two monitors. After logging out, then logging in again, I saw that the background was saved but not after restarting the computer.

I'm new in using Ubuntu but somehow know a bit about Linux and was able to set my first Ubuntu install yesterday (after deciding to leave Windows).

So, here's my guess: my wallpaper is not being found when I login because the image is in an internal hard disk drive that is probably not mounted upon login.

I copied my wallpaper from the unmounted HDD to somewhere inside my home folder (e.g. ~\Pictures\wallpapers\image.jpg) and set this image as my desktop background, and my problem was solved.

I hope this helps someone similar to my case. This is my first time posting in Ask Ubuntu, so I hope I'm not violating some rules such as necromancy. ^_^

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .