194

Every time I plug a USB stick in, nautilus opens a new window with the contents of the drive. I would like to disable this auto-opening of the nautilus window, but I would like the actual auto-mount to keep working. Is this possible?

5 Answers 5

303

The simplest option is to open a terminal with Ctrl+Alt+T, and type:

gsettings set org.gnome.desktop.media-handling automount-open false
10
  • 12
    This should be the answer. Nov 5, 2014 at 21:03
  • 3
    How shall I know which settings can be changed using gsettings set ? can you provide any documentation or list ?
    – MAKZ
    Feb 20, 2015 at 13:26
  • 1
    This doesn't work in Gnome-Shell. It still pops-up that notification asking to "Open with Files" or "Eject" or "Open with music player", etc.
    – Cerin
    May 5, 2015 at 14:47
  • 16
    Confirmed on 16.04. For an Android developer, this is really a relief! Sep 15, 2016 at 10:27
  • 4
    On Linux Mint this was gsettings set org.cinnamon.desktop.media-handling automount-open false for me. So cinnamon instead of gnome. Presumably this would have to changed also if you use Mate instead. Etc etc ... Nov 27, 2017 at 23:17
80

Turns out, it is. You will need dconf-editor tool, which can be installed by with sudo apt-get install dconf-tools. Run dconf-editor in your terminal. Browse to org -> gnome -> desktop - media-handling. Uncheck automount-open.

1
  • 3
    On Ubuntu 14.10, you just need to install "dconf Editor" (dconf-editor). Run it once it's been added to your Launcher. Then do the same thing.
    – colan
    Jan 3, 2015 at 1:48
21

The setting corresponding to izx's to disable automatically launching nemo in the cinnamon desktop is:

gsettings set org.cinnamon.desktop.media-handling automount-open false
0
1

For MATE Desktop Environment, which uses the Caja file manager:

gsettings set org.mate.media-handling automount-open false

or use Caja File Management Preferences (caja-file-management-properties) - on Media tab uncheck Browse media when inserted checkbox.

Not for Gnome or Cinnamon desktop environments, however MATE/Caja is a close relative.

0

Using GUI in debian gnome desktop:

Open dconf-editor then go to org -> gnome -> desktop - media-handling. There uncheck automount.

3
  • This will disable auto-mounting altogether. OP only wants do disable the pop-up windows after auto-mount. -1 Nov 29, 2017 at 11:59
  • yes, it disables the auto-mounting also. my answer is only for disabling pop-up window.
    – SHIVA
    Nov 29, 2017 at 12:55
  • No, it's not. Please read the description of the Dconf key org.gnome.desktop.media-handling.automount (“If set to true, then Nautilus will automatically mount media such as user-visible hard disks and removable media on start-up and media insertion.”) as opposed to .automount-open (“If set to true, then Nautilus will automatically open a folder when media is automounted.”). Nov 29, 2017 at 15:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.