I downloaded Ubuntu 12.04 using Wubi. The installation went correctly and everything was working fine until I tried to shutdown.

I clicked shutdown and then Ubuntu started shutdown, but as soon as I saw the Ubuntu logo with blank dots under, it froze. I had to perform a hard shutdown.

After booting my computer back and going into Ubuntu, I tried shutting it down again but this time it took me on a black page with lots and lots of log writing on the screen and after a little while, it stopped writing stuff.

I was able to input characters using the keyboard and everything, but it never shutdown. I had to perform a hard shutdown again.

Now it always gives me a Ubuntu logo and freezes. What should I do?

I know hard shutdowns are bad and want to avoid them. Is there anyway to make shutdowns work? I tried a reboot and it also froze on the Ubuntu logo.

  • Sony VAIO Model E SVE17115FDB Laptop.
  • Graphic card - AMD RADEON HD 7650M (and it installed correctly in Ubuntu).
  • BIOS - H2O Bios.
  • Processor - Intel i7-3612QM.


I only installed the AMD/ATI proprietary drivers FGLRX, not the AMD/ATI post release drivers because they keep showing an error message. Here is jockey.log.

Edit 2:

Here is the log that i mentioned before that appeared on my screen, it appeared after i tried reinstalling my AMD driver but failed so i reinstalled the other one. Sorry for the quality i took those pictures with my phone.

Edit 3:

This problem is indeed caused by fglrx (not the post-release one), i uninstalled it and my computer shutdowned wihtout a single problem, but i need those drivers to be able to change the brightness of my computer and without them Ubuntu is really, really slow. Is there anyway to fix this package?

  • Please include the text you got on your second shutdown attempt, especially the last few lines. It is imperative to copy them exactly. – ζ-- Sep 22 '12 at 0:21
  • I can't find the log anymore, it only gives the ubuntu logo with 5 blank dots but, it rebooted and shutdown'd itself correctly a little while ago after i updated some packages. Just now i tried rebooting it to go into my Windows 7 but i got stuck on blank dots again. I'll go back into ubuntu and check if i can shutdown properly now. – D3s7 Sep 22 '12 at 0:58
  • Yup it still freeze on the ubuntu logo while shutting down. – D3s7 Sep 22 '12 at 1:17

I would guess it is cuz of kernel options.

Just read this page and try some of them.

Boot Options

I once needed the following. (But you have to find out yours for yourself - as long as no one pops up with the same model and knows which one to add exactly)

irqpoll nolapic noapic

They tell you on this page how to get along. Hope that fixes this nasty problem.

  • 1
    Please include more details on how to do this for the OP. – ζ-- Sep 22 '12 at 0:21
  • I don't understand really, It's the first time i install Ubuntu. Also I installed it with Wubi, not a Live CD. – D3s7 Sep 22 '12 at 1:20

OP here, I fixed the problem. For anyone having this problem too, here is the solution : I purged my FGRLX install by using those commands :

sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

Then i rebooted (and was forced to Hard shutdown again). I checked and FGRLX was not there anymore. I went on AMD's website and selected the drivers I needed : Notebook Graphics -> Radeon HD Series -> Radeon HD 7xxxM Series -> Linux x86_64. Then i ran amd-driver-installer-8.982-x86.x86_64.run on a terminal and installed the drivers. After a reboot, everything was working fine and I can shutdown the computer correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.