When I'm connected to a wireless network from quite far away I sometimes briefly lose the connection. Then Network Manager prompts me to re-confirm the password as if it suspected that was the problem that caused the loss of connection (the password is already filled in in the dialog box).

  1. Is this normal behaviour?

  2. Can I prevent it from happening and have Network Manager automatically reconnect without the password dialog box when the wireless network comes back into range?

I'm using 10.04 (32bit, Gnome) on an Acer Aspire one.


1 Answer 1


1) Yes. Or at least, it's always done the same for me!

2) Not directly. You can edit the connection to prevent it connecting automatically, which is one workaround.

Alternatively, when it asks for the password just click Cancel, then select the network again from the Network Manager icon; it will reconnect as normal (using the stored password).

Wireless settings

  • 1
    This solution is not very satisfying.. This leaves the computer offline until you see it's offline and actively reconnect it... Windows and Macos automatically reconnect without any intervention, while Ubuntu has this silly behaviour for about a decade. Jul 11, 2017 at 9:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .