79

I've installed phpmyadmin sudo apt-get install phpmyadmin. Of course, I have also mysql and a web server running properly.

Now how can I reach it?

2
  • It depends on what web server you're using and how you set it up?
    – karthick87
    Dec 28, 2010 at 17:23
  • Read phpMyAdmin from ubuntu documentation
    – Darshana
    Sep 13, 2014 at 6:44

4 Answers 4

139

Did you try http://localhost/phpmyadmin?

Edit: Do this first

sudo nano /etc/apache2/apache2.conf

add this line somewhere

Include /etc/phpmyadmin/apache.conf

and finally restart apache.

sudo service apache2 restart
6
  • yes. And it doesn't work. "localhost" is working properly, since it display me the standard web page of the server.
    – mcastel
    Dec 28, 2010 at 16:41
  • Worked for me, weird though, since it worked on another server without adding this line...
    – n3rd
    Aug 3, 2012 at 0:12
  • 3
    This worked for me: ln -s /etc/phpmyadmin/apache.conf /etc/apache2/sites-enabled/001-phpmyadmin May 5, 2014 at 4:33
  • 3
    I tried adding the Include and I got a fail while restarting. Jul 19, 2014 at 19:50
  • hello myphpadmin page is not started.what should i do? Jan 24, 2017 at 17:21
24

You probably skiped the configure from the package.

Try this cli:

sudo dpkg-reconfigure phpmyadmin

And when it choose the webserver to configure, select apache.

2
  • 8
    Simply forgot to tick the [ ] apache with the spacebar on install.
    – DKSan
    Nov 1, 2016 at 7:33
  • 3
    I also discovered that the little red square is not an “accept” symbol!
    – Tim
    May 30, 2018 at 11:53
8

It depends on your configuration.

From my experience, I may reach with localhost/phpmyadmin but fail to login, I have to reconfigure phpmyadmin, reset MySQL password, and then I may login without problems.

  1. Reconfigure phpmyadmin
  2. Ctrl+Alt+t to launch terminal
  3. sudo dpkg-reconfigure phpmyadmin
  4. Connection method for MySQL database for phpmyadmin: unix socket
  5. Name of the database's administrative user: root
  6. Password of the database's administrative user: mysqlsamplepassword
  7. MySQL username for phpmyadmin: root
  8. MySQL database name for phpmyadmin: phpmyadmin
  9. Web server to reconfigure automatically: apache2
  10. ERROR 1045
  11. ignore
  12. sudo dpkg-reconfigure mysql-server-5.5
  13. New password for the MySQL "root" user: mysqlsamplepassword
  14. Repeat password for the MySQL "root" user: mysqlsamplepassword

But if your problem is fail to interpret php, follow the instruction to enable your php first.

  1. sudo gedit /etc/apache2/mods-available/php5.conf
  2. look for php_admin_value engine off, between and
  3. Add # in front of php_admin_value engine off to disable it.
  4. REMEMBER! Don't change the value php_admin_value engine from off to on!
  5. sudo /etc/init.d/apache2 restart

Wish it helps!

Have a nice day!

0

If you have changed the port in which Apache is listening on, default is 80;

sudo nano /etc/apache2/ports.conf

look for the Listen port should look like

Listen 80

if that port is diffrent in order to get into phpmyadmin your url must point to that port

example

localhost:port/phpmyadmin/

change the port number to the one you have in the /etc/apache2/ports.conf

Not the answer you're looking for? Browse other questions tagged or ask your own question.