1

I had installed Ubuntu 12.04 i my Toshiba Laptop Satellite C665-I5011

In this I am not able to change the LCD brightness. When i press Fn+F6 or Fn+F7 the brightness bar is changing but the LCD screen brightness is not changing.

Can someone help me in this to solve this?

  • Possible duplicate: askubuntu.com/questions/130819/… – devav2 Sep 20 '12 at 13:58
  • are the other fn keys working? – ecoologic Sep 20 '12 at 14:04
  • yes..other function are working.. i tried volume Fn+3 and Fn+4 – Dino Sep 20 '12 at 15:06
  • Is your problem same as the one linked above? – Anwar Sep 23 '12 at 3:54
  • Have you tried from Sistem Settings? – AliNâ Feb 12 '13 at 22:01
1

Try this:

  1. Open a terminal (Ctrl + Alt + T).
  2. Then type sudo nano /etc/default/grub. It will ask for your password. Type it in.
  3. Around the 11th line, there will be something like: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash". Change it to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
  4. Save the file by Ctrl+O followed by Ctrl+X. Then run sudo update-grub in the terminal.
  5. Reboot and see if backlight adjustment works. If not, undo the changes you did above, by invoking the text editor as in steps 1 and 2.

Hope it helps.

  • this i had tried..it did not work for me – Dino Oct 6 '12 at 1:53
1

Launch synaptic packet manager. Type in ACPI, check acpi 1.61 and acpitool 0.5.1-3,mark for installation,click apply and then reboot or restart.

Should work.

Worked for me on Toshiba satellite L450D-11V.

1

Did it work? Have the same problem. Couldn't fix it and wrote a skript in gedit:

#!/bin/sh

SYSFILE=/sys/class/backlight/acpi_video0/brightness
MAX=`cat /sys/class/backlight/acpi_video0/max_brightness`
CUR=`cat $SYSFILE`

RET=`zenity --scale --value=$CUR --max-value=$MAX`

echo $RET | sudo tee $SYSFILE

started it in the terminal. Its not the best solution, but works.

0

try this package and see if it's working after a reboot:

sudo apt-get install fnfxd fnfx-client

if you need acpi, you can find them here:

http://manpages.ubuntu.com/manpages/hardy/man4/acpi_toshiba.4.html

  • update-initramfs: Generating /boot/initrd.img-3.2.0-29-generic Reloading the module ERROR: Module toshiba_acpi does not exist in /proc/modules FATAL: Error inserting toshiba_acpi (/lib/modules/3.2.0-29-generic/kernel/drivers/platform/x86/toshiba_acpi.ko): No such device dpkg: error processing toshiba-acpi-fix (--configure): subprocess installed post-installation script returned error exit status 1 Setting up fnfx-client:i386 (0.3-14ubuntu1) ... Errors were encountered while processing: toshiba-acpi-fix E: Sub-process /usr/bin/dpkg returned an error code (1) i get the above error – Dino Sep 20 '12 at 15:06
  • did the solution in the "possible duplicate" worked? if that solves the problem it would be easier than installing the acpi through the link in my answer (which is what your error is about) – ecoologic Sep 20 '12 at 15:27
  • it did not work :( – Dino Sep 21 '12 at 7:33
  • is there anything in the kernel i need to enable and re-compile ?? – Dino Sep 21 '12 at 7:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.