3

I need to install Mysql-server-5.6 in my ubuntu development server 12.04. Now it is running percona-server5.5. How can i upgrade this to mysql-5.6 ?

2
  • tried deb and rpm package but no help.
    – nav
    Sep 22 '12 at 18:39
  • I tried them too. Found out that they don't work out of the box, not to mention not playing well at all with Ubuntu standards (file locations, init scripts, conflict handling etc.). See my detailed answer below. Feb 25 '13 at 23:51
6

I have prepared experimental PPA with MySQL 5.6 packages based on MySQL 5.5 Debian packages. No guarantee that it will work right away, but I would be grateful if you can try it and report back success (or failure).

The PPA can be found at: https://launchpad.net/~ondrej/+archive/mysql-experimental

There's also a MySQL 5.5 PPA with latest upstream release found at: https://launchpad.net/~ondrej/+archive/mysql

4
  • Please don't post the exact same answer to multiple questions. While it's certainly useful, this is not considered the nicest thing to do; "rep chasers". Instead, I think you can comment with a link to the question with useful answers.
    – gertvdijk
    Jun 24 '13 at 13:53
  • 1
    @gertvdijk Ok, will do next time. The real problem is that those questions should be marked dupes.
    – oerdnj
    Jun 24 '13 at 14:01
  • 1
    You're right. Marked as such.
    – gertvdijk
    Jun 24 '13 at 14:07
  • @gertvdijk I did as well (also on all the other duplicates).
    – oerdnj
    Jun 24 '13 at 14:10
2

I have just written a blog post about upgrading mysql on ubuntu 12.04. You can find my post at http://www.peterchen.net/2013/02/20/en-how-to-install-mysql-5-6-on-ubuntu-12-04-precise/. Hope this will help you.

2
  • 4
    Please include the essential details of the link in the answer itself.
    – ignite
    Feb 20 '13 at 5:08
  • @IgnitE is right, because now the link is broken, and so this answer is currently not helpful. However, I saw this article and it's quite long; I'd argue too long to post as an answer, and thus a link is warranted. Jul 29 '14 at 22:44
1

this tutorial shows you in details how to.. But note that this is done to upgrade to 5.5 i think it's the same for 5.6

3
  • You are welcome but if you find this answer is useful please make an upvote by clicking on the up arrow on the left side of the answer
    – user61928
    Sep 24 '12 at 5:26
  • 1
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – gertvdijk
    Jun 24 '13 at 13:47
  • You'd get more upvotes if you actually answered the question. The problem with links is they eventually expire and your answer becomes worthless. Apr 17 '14 at 5:05
1

I think you should stay with Percona. Both Percona and MariaDB are much better supported, especially on Ubuntu, than the Oracle MySQL distributions. Going the Oracle route will lead to many incompatibilities with how software is being managed, configured, started/stopped, etc. on Ubuntu (or other debian derived distros).

5.6 is very new (as of Feb 2013 the package minor is alpha-60) so the apt-get method is not yet fully supported (for server-5.6) by Percona, as far as I can tell. You can however download the 5.6 *.deb packages for Ubuntu 12.04 from percona.com/downloads/ and then use 'sudo dpkg -i' locally to install them.

I would strongly advise against installing RPM packages on Ubuntu/Debian due to many incompatibility issues that may arise.

Another alternative, and IMHO a better one, is to stay with 5.5 (latest is actually 5.5.29 so it already includes many of the goodies from 5.6) for a while longer, and switch to 5.6 (package name: percona-server-server) once it is out of alpha. It shouldn't be too long now. To do so follow the instructions here

Not the answer you're looking for? Browse other questions tagged or ask your own question.