I was finally able to connect to avasys.jp and downloaded and installed iscan_2.28.1-3.ltdl7_amd64.deb iscan-data_1.13.0-1_all.deb. The programs appeared to install correctly.

I then ran sane-find-scanner and got back:

found USB scanner (vendor=0x04b8, product=0x012d) at libusb:001:003

I then ran lsusb and got back:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 04b8:012d Seiko Epson Corp. Perfection V10/V100 (GT-S600/F650)
Bus 001 Device 004: ID 03f0:4817 Hewlett-Packard 
Bus 002 Device 002: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse

the avasys image scan manual instructed me to run

chmod 0666 /proc/bus/usb/001/003

which returned

chmod: cannot access `/proc/bus/usb/001/003': No such file or directory 

In 12.04, no such directory exists. 12.04 appears to deal with USB in another way.

What must I do to get the usb port 001/003 recognized by xsane and sane as the port where the scanner can be located? What must I do to continue installing the scanner?

  • 2
    Run sudo apt-get -f install from the terminal to try to fix dependency issues. – ish Sep 20 '12 at 8:08
  • I tried that, it seems to produce the same results as running sudo apt-get install libsane-extras In any event I still get dependency problems on trying to install above – Howard Graham Sep 20 '12 at 12:10
  • @HowardGraham Have you used dpkg -i filename.deb If you are root this installs the .deb package. – NlightNFotis Sep 21 '12 at 6:11
  • This answers on this question might help as they relate to Epson V series and other scanners – user76204 Nov 29 '12 at 15:07

I had a similar problem trying to make scanning to work with my Epson Perfection V300 Photo, and using the guidance above, I found:

  • Epson scanner software for Linux is now on the Epson site, here: http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
  • I installed 2 files: the *iscan_2.29.1-5~usb0.1.ltdl7_amd64.deb* (you may need a different version) and *iscan-data_1.19.0-1_all.deb* - but the scanner software still claimed there was no scanner
  • I also needed to download and install the iscan plugin package (*esci-interpreter-gt-f720_0.1.1-2_amd64.deb*) from the Epson site (this isn't very clear in the PDF documentation for Image Scan! that you can download, though it is hinted at)
  • all 3 packages installed through the 12.04 software centre simply by double clicking on them

I hope this helps.

  • Where can you find this iscan plugin package (*esci-interpreter-gt-f720_0.1.1-2_amd64.deb*)? It's not listed with the other packages on the provided url. – Redsandro Jan 30 '14 at 16:02

I had exactly the same problem with iscan-2.29.1-5 and iscan-data_1.19.0-1, downloaded from Epson and run on 12.04 LTS with an Epson V350 attached. Simple Scanner says "No scanners detected. Please check your scanner is connected and powered on." The earliest version available from avasys seems to be 2.28 but these don't work either, giving the same result (no scanners detected error).

A working fix was to run the following, in the order listed:

dpkg -i iscan-data_1.8.0-0_all.deb
dpkg -i iscan_2.26.2-1.ltdl7_i386.deb
dpkg -i iscan-plugin-gt-f700_2.1.0-3_i386.deb

I had these files saved from a couple of years ago - it seems they are no longer available on the web.

Hope this helps someone, even if only to save the time I wasted trying to get the current version and the oldest version available at avasys to work.


You can find these deb packets on http://download.ebz.epson.net/dsc/search/01/search/searchModule

Just write "perfection v10" or the version of your scanner and "Linux" in the operating system, and you will find them.

I have installed the Epson Perfection v10 on Linux Mint 13 and works fine.

These deb will install "Image Scan! for Linux" which is similar than the Windows program you installed with Epson drivers.


I have an Epson GT-S80 which I couldn't get to work.

After going through a number of answers I've finally found a process that worked perfectly

Try this....

Installing an Epson GT-S80 (I'm sure this would work for others)

1 – Check whether computer is a 32 or 64 bit configuration

(Terminal) $ uname -a <enter>

x86 = 64b 1386 = 32 bit

2 – make sure Scanner is attached to the pc & switched on

Locate product id

(Terminal) $ lsusb <Enter>

Probable result = ID 04B8:0136

3 – Ensure user is in scanner group

(Terminal) $ id <Enter>

You are looking for 109 (Scanner). If not there, type in the following command

(Terminal) $ sudo adduser XXXX scanner <Enter>  (Where XXXX = the username)

Restart computer and Recheck

(Terminal) $ id <Enter>

4 – Set Device ID for Sane Daemon

(Terminal) $ sudo leafpad /etc/sane.d/epson* <enter>  (A window full of text will jump-up)

on the line that has # usb 0x4b8 0x110 Remove the # and change the 110 to 136 (assuming that was the id you identified earlier)

Should now look like : usb 0x4b8 0x136

Save the file and close now

(Terminal) $ sudo leafpad /etc/sane.d/epson.conf <enter>

At the bottom do the same thing with the #usb line

Also remove the comment (#) symbols on the lines that read

usb /dev/usbscanner0
usb /dev/usb/scanner0

Save and close the file


(Terminal) $ sudo leafpad /etc/sane.d/dll.conf <enter>

place comment (#) tags before both epson entries


Save & close the file

5 – Empty your downloads file. This will prevent confusion later

5 – Download the Iscan software From the epson website

You need three files from the site

Google Epson linux drivers which will bring up the correct download site Start with the core package & data package

Accept then download (save file) deb file with ltdl7 for whichever system configeration you identified earlier

Then download & save iscan-data_1.28.0-2_all.deb file

Return to download center & go into iscan plugin package

Accept then download the .deb package for whichever system configuration you have

6 – CD to the downloads folder

(Terminal) $ cd Downloads <enter>

you should see path change to ~/Downloads$

If you type ls into the terminal you should see only the three files you've downloaded. This is why you emptied it earlier

7 – Install the dependency (it won't work if you don't)

(Terminal) $ sudo apt-get install xsltproc <enter>

8 – Install iscan pakages

(Terminal) $ sudo dpkg -i * <enter>

9 – Run program If you get the 'Could not send command to scanner Check the scanner's status' error Disconnect the scanner & switch off, restart pc, reconnect and turn back on everything.

10 – lastly You can fix a number of installation errors using the following simple code

(Terminal) $ sudo apt-get -f install <enter>

Should now work.


Here's mine Do these in the following order

  1. Install libltdl3_1.5.26_1ubuntui386.deb
  2. Install iscan-data_1.15.0-2_all.deb
  3. Install iscan_2.28.1-3_i386.deb
  4. Install esci-interpreter-gt-f770_0.1.1-2_i383.deb I have the files and they work.

If you need them email me. If the need is too great. I'll post them on my file server Ubuntu 12.04 3.2.0-37-generic , Ubuntu 11.mn probably uses something like kernel 2.24?


I had to install xsltproc and libjpeg62 then I did dpkg -i iscan-data_1.22.0-1_all.deb iscan_2.29.1-5~usb0.1.ltdl7_amd64.deb and it works flawlessly with my Epson Rx600 Photo printer / scanner which is like ancient


You need to install the core package/data and tje iscan plugin package. Search for V30 on this page.

enter image description here


On Ubuntu 12 64bit, this worked for WF-2530.

Went to the Epson download center and downloaded following and ran them in the following order.:

 sudo dpkg -i iscan-data_1.24.0-2_all.deb
 sudo dpkg -i iscan_2.29.2-1~usb0.1.ltdl7_amd64.deb

Then used xsane scanning software


To install drivers for Epson XP-211 on Ubuntu 13.10 I did the following

Go to http://download.ebz.epson.net/dsc/search/01/search/searchModuleFromResult

Select and download all the deb drivers

Install with Software Center

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.