I got my brand new Dell Inspiron 14z yesterday, but failed to install Ubuntu.

I can boot from a USB stick, and it works well. When trying to install, I confirm that the laptop is connected to the Internet etc (as in the 2nd picture in the installation guide: How do I install Ubuntu?). When pressing "Continue" I do not get the question on installation type (alongside/replace/something else). Instead I get a window where I can select partitions:

enter image description here

The problem is that I can only select sdb in the drop drop down box, and I can do do nothing with sdb (like adding partitions etc).

The main disk (sda) is partitioned using GParted the following way:

enter image description here

As far as I understand from other posts on Ask Ubuntu, this should work.

What can I do to install Ubuntu alongside with Windows 7?


1 Answer 1


It seems you have a small SSD (/dev/sdb) and a hard drive (/dev/sda) that uses Intel Smart Response Technology, that Ubuntu recognizes as RAID0.

  1. Boot from USB stick and select "Try Ubuntu"
  2. Open a terminal by pressing Ctrl+Alt+T and enter sudo dmraid -E -r /dev/sda.
  3. Using Gparted delete the extended partition /dev/sda4 and all the logical partions inside it (sda5, sda6, sda7).
  4. Start the Install Ubuntu process as before.

(The above worked)


If you have the Intel Smart Response Technology:

  1. Deactivate it from within Windows using the GUI,
  2. Change the SATA mode in the BIOS from RAID to normal.

Then your Ubuntu installer should recognize both disks. (But beware, I don't know how Windows or rather ntfs behaves if you deactivate the RAID mode. Your ntfs filesystem could also get damaged) From No HDD shows up during install 12.04 on Lenovo U410.

Once the RAID is removed you should get the "alongside" option. However, you may choose "something else" and use the small SSD for the / partition and the the HDD for /home and swap. See Is it safe to install the / partition on an SSD?

Hope this helps

  • This was what I tried before adding the extended partition on sda. I have now removed the logical partitions again, and removed also the extended partition. sda1 - sda3 are as before (with Win7), and there is now an "unallocated" part of sda of 214.93 GiB after sda3. Still no change... I do not get the option to select "alongside" and I can only select sdb in the dropdown, just as before. Commented Sep 20, 2012 at 5:11
  • Do you have a small ssd along with the hard drive with Intel's "Smart Response Technology?" IF so, see this askubuntu.com/questions/164980/…. Otherwise, I am out of ideas.
    – user68186
    Commented Sep 20, 2012 at 12:31
  • This post seems to be the same issue: askubuntu.com/questions/182179/… . Will I get any problems removing Raid info on the disk (if that is my problem as well? Commented Sep 20, 2012 at 18:45
  • I am not sure if disabling RAID will damage the Windows ntfs file system. Proceed with extreme caution. You may lose all the data and have to reinstall Windows.
    – user68186
    Commented Sep 20, 2012 at 21:15
  • OK, thanks. I will try when I get a chance (in a couple of days hopfully). Since it is a new PC it is no problem to re-install Win7... A bit curious though what the RAID is good for... Commented Sep 21, 2012 at 9:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .