Just added 2 pci-e to ide cards in my computer so I can use 2 old ide hard drives. Everything works fine, except the OS booting time has gone from about 10 seconds to about 10 minutes...

I'f I remove both cards, it takes about 10 seconds to boot up, if I add either 1 of the cards back in, it still takes 10 seconds to boot up, but as soon as I have both cards in, it takes about 10 minutes.

Why would this be happening?

  • Are you still having this problem? – ζ-- Sep 25 '12 at 0:14
  • Just wondering,what did you do? Chage IRQ's? Or put both disks on the same card? – ζ-- Sep 26 '12 at 14:53
  • I put both disks on a single card and changed the jumpers as you mentioned. – oshirowanen Sep 26 '12 at 14:55
  • You don't even need the second card unless you want more then two disks. – ζ-- Sep 26 '12 at 15:22

It appears that there is an IRQ conflict. Both cards are set to the same "channel", and thus are conflicting. You must find a jumper or dip switch setting for IRQ and set it to something that no other device in your computer uses. You need not worry about plug-and-play devices as they will auto-resolve their conflict. As to changing the IRQ settings, this depends on your hardware.

However, since you wish to add two disks, you only need one such card. You simply need an IDE cable with three connectors: one for the card, and two for disks. These are quite common.

enter image description here

CARD-------DRIVE 1(MASTER)-----------------------------DRIVE 2(SLAVE)

Make sure one of the drives is a master, and the other is a slave, or both use the Cable Select (CS) feature, as per their jumper settings. The order of master-slave on the cable doesn't matter if you aren't booting from wither of the drives, but if you are using CS, both drives must be in CS mode, and then they will automatically detect master/slave by their positions on the cable.


Maybe you could check dmesg for errors or other clues? In terminal:

dmesg | more

Maybe pastebin it look for stuff related to the cards you added.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.