1

When I try fgl_glxgears, I'm getting a framerate of under 60 fps. All the forum posts and askubuntu posts I've read suggest that I should be seeing at least triple digits. When this machine had windows installed it was pretty decent running games like WoW at around 60-70fps.

$glxinfo

name of display: :0.0 display: :0  screen: 0 
direct rendering: Yes 
server glx 
vendor string: ATI server 
glx version string: 1.4

$fglrxinfo

display: :0.0  screen: 0 
OpenGL vendor string: Advanced Micro Devices, Inc. 
OpenGL renderer string: ATI Radeon HD 5670 
OpenGL version string: 4.2.11733 Compatibility Profile Context

$dpkg -l fglrx* | grep ^ii | awk ' { print $2 }'

fglrx
fglrx-amdcccle
fglrx-dev

I followed this procedure from another post, and saw some increase in performance.

  1. sudo apt-get purge fglrx fglrx-dev fglrx-amdcccle
  2. sudo apt-get install fglrx-updates fglrx-amdcccle-updates

fgl_glxgears = 80-90 fps glxgears = ~300 fps

Which is more than double previous rates, but I see people with excess of 1000 fps. Am I missing something?

Update 2

I've tried installing the proprietary drivers by following the instructions https://help.ubuntu.com/community/BinaryDriverHowto/ATI with much the same result.

Update 1

Interestingly, If I minimize glxgears while it's running, I see a fps rate of 5300+.

Bonus points:

Also, there's this annoying little habit of games to somehow shut off my second monitor. Is there a way to stop that? (when full screen is enabled)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.