I have been able to install Ubuntu 12.04 with LAMP MySQL version 5.5.x

It works fine within linux, it allows me to connect from myodbc windows vista or windows 7

I have configured networking access and have been able to access from windows vista using putty and other tcp connections like mysql query browser.

I have also configured or disabled ufw firewall and apparmor.

The connection works fine until I query data from the tables.

It lets me query small amounts of data like: SELECT name FROM users limit 20 but if I do a SELECT * FROM users, it goes on a never-ending loop. This happens even on tables with very few records like 5 or even less.

The problems occur with windows because I tried ssh from linux mint and it worked fine. I need to be able to work using MyODBC either 3.51 or 5.1 since my client program is made in VB6 and connects to mysql server via tcp/ip.

The server is an HP PROLIANT ML350G6 with Intel Xeon 64 bits.

I tried several ubuntu server version (12.04 64bit, 10.10 64bit, 11.04 32bit) and none has worked I even tried CentOS 6.3 and the same.

As a reference, it works fine with onother ubuntu server version 6.x on HP Proliant 150 and mysql 5.0.x that is like 7 years old and never updated.

Help Please.


It is too bad nobody has responded to my question. I will add some new clues:

1) The queries work well from Windows XP to old and new MySQL linux versions on 32 or 64 bit server. 2) Windows Vista or 7 fails to query on the new MySQL versions

My guess is that newer Windows are sabotaging the queries on newer versions of MySQL/linux servers.

Could somebody tell me a possible solution or configuration fix.


  • Adding to my own comments: – jorgearr Sep 25 '12 at 16:04
  • The problem only happens on windows tcp/ip wireless. I tried on wired network and it works. – jorgearr Sep 25 '12 at 16:13
  • When I open an ssh connection with putty I log into ubuntu server fine, open small file fine, list with ls small directory fine, but if the directory is bigger than the screen page it will stall. Like ls /etc/ will stop on the first page and hang. Please help. – jorgearr Sep 26 '12 at 15:27
  • My real problem is wireless, I can connect and query the first results, apparently mysql sends all data but my windows screen halts at the first page. Would you kindly help? I need to be able to get all data through wireless on Windows Vista and Windows 7. – jorgearr Sep 27 '12 at 3:26
  • The weird thing is that it only fails on WiFi from Windows (tried from Vista and 7). It works when connected from Linux Mint WiFi. – jorgearr Sep 28 '12 at 17:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.