2

Running: Linux ips-svf-1 3.0.0-22-server #36-Ubuntu SMP Tue Jun 12 17:56:20 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

I'm trying to free space in /boot with apt-get -y purge, but every time I run the command I get an error about unmet dependencies:

sudo apt-get -y purge linux-headers-3.0.0-12
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 linux-headers-3.0.0-12-server : Depends: linux-headers-3.0.0-12 but it is not going to be installed
 linux-image-server : Depends: linux-image-3.0.0-26-server but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

However, I can't run apt-get -f install since /boot is full.

I also tried running dpkg --purge and dpkg --remove manually, but both give the same unmet dependency error.

Any suggestions on how I can successfully free space in /boot? Is there anything I can safely delete with rm?

1
0

use with caution

dpkg --force-depends ....

or use with caution

dpkg --force-all ....

For more information invoke:

dpkg --force-help
5
  • That's working to allow dpkg to proceed, but strangely, df is showing no change in blocks used in /boot. Boot is still 100% full Any idea why? – wadesworld Sep 18 '12 at 13:16
  • 1. Check if some slack like core files are below /boot – H.-Dirk Schmitt Sep 18 '12 at 13:34
  • 2. Purge some unused kernels (check before with uname -a which kernel is running) – H.-Dirk Schmitt Sep 18 '12 at 13:35
  • (Most likely 3.0.0-12 and 3.0.0-26 are not properly installed.) – H.-Dirk Schmitt Sep 18 '12 at 13:36
  • Ah, got it now - I was purging headers (which were at the top of the list) and not seeing space freed because they were so small. Once I purged an actual kernel, enough space was freed so I could run apt-get -f install and then could purge the remaining kernels with plain old apt-get purge -y <kernel> – wadesworld Sep 18 '12 at 14:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.