I have a Kingston 2GB MicroSD and I plug it in via an inconix MicroSD Adapter to the internal card reader of my Samsung N210 Netbook with Ubuntu 10.10, but it doesn't show up. Only if I reboot the system when the card's plugged in it shows up. Why does it need a reboot for mounting?

sudo fdisk -l gives the output below. But I can only see the drive when I reboot the computer while the card's plugged.

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x9a5a7990

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1        1959    15728640   27  Unknown
Partition 1 does not end on cylinder boundary.
/dev/sda2   *        1959        1972      102400    7  HPFS/NTFS
/dev/sda3            1972       18992   136718750   83  Linux
/dev/sda4           18992       19458     3738625    5  Extended
/dev/sda5           18992       19458     3738624   82  Linux swap / Solaris

Disk /dev/sdb: 1973 MB, 1973420032 bytes
60 heads, 59 sectors/track, 1088 cylinders
Units = cylinders of 3540 * 512 = 1812480 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1        1089     1927100+   6  FAT16
  • 1
    Please update your question with the output from command "dmesg" when you plug it. – João Pinto Dec 27 '10 at 11:59
  • 1
    How do I do that? I wrote dmesg in the terminal but it was too long and it cropped the beginning of the output. – hattenn Dec 27 '10 at 12:49

Workaround: Try after insert sd card to slot run as root

echo  1 > /sys/bus/pci/rescan
  • Ubuntu 12.04.2 LTS: Permission denied when using that command, I've used sudo, I've used chmod +x, I've used root nautilus and changed root permissions and you can't change it. – Ads20000 Jul 31 '13 at 7:32
  • @Ads20000: You probably ran sudo echo 1 >... − this will not work. Use tee with sudo to write to the file. – Léo Lam Dec 29 '14 at 17:57
  • Redirection is done by shell, which is not running as root, only echo. You want to run shell as root and call make redirection from there: sudo bash -c 'echo 1 > /sys/bus/pci/rescan' – Sergiy Kolodyazhnyy Oct 20 '16 at 19:53

It is likely your card has been accessed many times, and is beginning to show its age. I've had SD cards do this often.

Unfortunately there is not much of a "solution" - the only thing you can do really is manually mount the card (usually just a matter of going to "Computer" in nautilus, right clicking the SD card, and choosing mount).

After looking at your output etc, it seems your adapter is faulty/being turned on after the system has been on at least once (thus only shows up on reboot - hard to explain what I mean correctly). Maybe it is a hardware problem.

  • There is no SD card that I can mount in Nautilus. It doesn't show up at all. – hattenn Dec 27 '10 at 12:46
  • what is the output of sudo fdisk -l? add it to your question :) – RolandiXor Dec 27 '10 at 13:43
  • I've added the output of sudo fdisk -l – hattenn Dec 27 '10 at 20:37

i found the temp solution. insert and remove card 5 times. it works on fifth time.

  • 1
    :D That's good. Well I've installed Ubuntu 10.04, the problem persists but your solution doesn't work. I've no way to try it on 10.10 right now as I'm not using it anymore. But thanks, I'm upvoting for the "fight till the computer does what you say!" method! – hattenn Jan 7 '11 at 11:54

I had a similar problem with Ubuntu 10.04 onto Acer Extensa 5620-4020. I tried different recipes but no one help me. On this PC I have also WinXP and the same SD card just works fine. Accidentally I found the solution :-) May be ( this is my simply opinion ) some timing in Linux kernel/drivers is not long enough and after years of use the contacts on SD card or contacts on the PC socket become bad. If I just push the SD card Ubuntu doesn't recognize it, BUT, if I push the card SLOWLY I always have a mounted SD card and Ubuntu pop up a window to ask me do I wish to open my digital photos with Open F-Spot. Hope this can help you.


This may be totally off but I had--and solved--a similar problem. If I booted my laptop (Ubuntu 10.10), the card reader wasn't recognised. However, if I rebooted with a card in the card reader, it was recognised. After much searching and head scratching, I stumbled upon the solution while enabling VMX extensions in the BIOS...

There was an (enabled) BIOS setting to make the card reader use a 'power saving' mode. I turned off this setting and sure enough, the card reader was recognised when the machine booted; without having to insert a card at boot time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.