I want to try Ubuntu on a hp pavilion g7-1246ef computer. I got it as a 64 bit system with a win7 64 bit but now it runs a 32 bit win 7 (due to canon printer driver issue).

The Windows device manager displays:

enter image description here

I have created a live USB and then CD of Lubuntu 12.04, a live usb of Ubuntu 12.04 (all 32 bit), and tried to boot in each of them, set to boot from usb, reached the page with try ubuntu but then selecting it nothing happened, or so it seemed: in fact using a 64 bit Ubuntu 12.04 live usb I was first under the same impression but when I pushed power off I realized a window was barely visible on an almost black display, and even folder icons were there but almost invisible.

I guess there are no video drivers for this system.

enter image description here

Is there a solution?

[This is a late edit just to put things right for reference: even without nomodeset and without the proprietary driver, my machine would still work: just that the startup luminosity level was zero and had to put it up manually.] (I do not currently use ubuntu/linux on that machine, was just interested for a solution in such cases.)

UPDATE for 14.04

With the new 3.13 kernel that video card is now well supported - more details here and here.


It seems(from your image) that you have a Radeon graphics card... This may be the problem

When you reach to try Ubuntu page, press F6 and select nomodeset option and then select Try Ubuntu and hit enter... Ubuntu will run the setup with basic Graphics. Then you'll be able to try/install Ubuntu...

While using a live USB boot, the try ubuntu page may have other options (e.g.use tab to edit): you have to edit so as to add nomodeset there: it has to look like that: quiet splash nomodeset

Then, continue to try ubuntu or install.

Hope that works :)


  • it works perfectly, but only in live cd, not in usb, or i'm not able to find that nomodset command in usb. can you advise me ? As for the rest i see no loss in display quality with nomodset although it gives me some errors on a no hardware response. i would prefer just to use ubuntu on this one from a live usb as the cd is noisy – user47206 Sep 17 '12 at 11:55
  • here might be the answer (have not tried it yet) askubuntu.com/q/147779/47206 – user47206 Sep 17 '12 at 12:03
  • When you get to the menu after booting from USB, There will be some options to edit the entries like "press 'e' to edit..." After doing so find the words: "quiet splash" and type nomodeset before quiet splash so it becomes: "nomodeset quiet splash" (Without quotes) then press Ctr + x (or F10) to boot :) – Sam Sep 17 '12 at 13:15
  • it also worked for me as in the edit that i made to your answer: quiet splash nomodeset – user47206 Sep 17 '12 at 13:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy