21

I have installed Ubuntu on my desktop, but my monitor don't pass more than 800x600 resolution.

My monitor is good at 1360x768. How can I set resolution at 1380x768 ?

marked as duplicate by BuZZ-dEE, Florian Diesch, user117103, Eric Carvalho, karel Feb 9 '14 at 4:05

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    In System Settings in Display U can not seeing Resolution settings? U can not adjust it through that? – Gaurav Sep 16 '12 at 3:17
  • Please post the output from the following command: lspci -nnk | grep -i vga -A3 – BuZZ-dEE Jan 30 '13 at 10:48
32

I'll show you an example of how you can set your monitor resolution.

Get the Modeline with the following command. 60 is the monitor refresh rate in Hz. You have to know your monitor refresh rate!!!

cvt 1360 768 60

The output looks like this. Copy the modeline after Modeline to use it in the next command.:

# 1360x768 59.80 Hz (CVT) hsync: 47.72 kHz; pclk: 84.75 MHz
Modeline "1360x768_60.00"   84.75  1360 1432 1568 1776  768 771 781 798 -hsync +vsync

Create a new mode with the copied modeline and xrandr.:

xrandr --newmode "1360x768_60.00"   84.75  1360 1432 1568 1776  768 771 781 798 -hsync +vsync

With the following command, you get the connected port.

xrandr --query | grep connected

The output looks like this. As you can see, in my case the connected port is DVI-0.:

HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 521mm x 293mm
VGA-0 disconnected (normal left inverted right x axis y axis)

Add the new mode using your connected port.:

xrandr --addmode DVI-0 "1360x768_60.00"

Change the monitor resolution.:

xrandr --output DVI-0 --mode "1360x768_60.00"
  • 1
    That fix works great per session, but when I reboot with the xrandr commands in a .xprofile file, the resolution is wrong. – noobninja Aug 18 '15 at 11:13
  • 1
    This solution is working, but only temporarily. After reboot, everything is gone. Does any one know where to add those modelines in Ubuntu 16.04, to make it permanent? – Robin Hsu Jul 12 '16 at 16:30
11

You should access System Settings - Display. There you'll see a Resolution drop-down menu. Just click on it an check the resolution you desire, as 1360x768. Then, just click Apply and you should see the changes.

Select System Settings

Select Displays from the list

Change your resolution

  • 1
    In fact, when I do these steps, the maximum resolution is 1024x768. But my monitor can handle 1280x1024. – Robin Hsu Jul 12 '16 at 16:31
  • 3
    Same problem here. As of Jan 2017 why can't Ubuntu fix this or pick up native resolutions without using some crazy command like xrandr and potentially blowing a monitor/laptop screen? – Rick Henderson Jan 6 '17 at 5:51
  • Yes I agree -- I have a 1280x800 monitor that Ubuntu just thinks goes to 1280x720 (over HDMI.) I would hazard a guess that approximately all users know about the display control panel, and the list of resolutions we can choose there, and the questions come when Ubuntu for some reason doesn't display a resolution that the monitor can do on other OS-es. – Jon Watte Apr 30 '17 at 5:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.